Plymouth-start.service [dmesg]

systemd[1]: /usr/lib/systemd/system/plymouth-start.service:15: Unit configured to use KillMode=none. This is unsafe, as it disables systemd’s process lifecycle management for the service. Please update your service to use a safer KillMode=, such as ‘mixed’ or ‘control-group’. Support for KillMode=none is deprecated and will eventually be removed.

please help, noob here, what to do. saw a bug reported, no resolve

1 Like

ran this, still getting same warning with dmesg

sudo dnf update Plymouth
[sudo] password for db:
Last metadata expiration check: 2:16:56 ago on Wed 09 Dec 2020 04:05:43 PM EST.
No match for argument: Plymouth
Error: No packages marked for upgrade.

Spelling is wrong. As a general rule all packages use lower case in the names and plymouth is no exception. I would try “dnf reinstall plymouth” instead.

My system in that file has KillMode=none and I have had no issues with it. What exactly was your error that prompted you to do something with plymouth.

FYI, There’s an upstream bug filed. Systemd 246.2 complains about KillMode=none in plymouth-start.service (#123) · Issues · plymouth / plymouth · GitLab



Thanks savvy, I did the reinstall and still get the same error. I researched into link sent by grumpey a little deeper and the bug is filed and being worked on. Thank you both for the quick replies,

Not sure if it was a real issue or not, my machine seems to be performing well, just saw the above error running [dmesg]. Trying to learn to troubleshoot system and keep my OS maintained. Any pointers are very much appreciated. Been doing a lot of reading while trying to learn the shell world and hardening.
Thx again savvy

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.