PC refuses to see two HDMI ports, except when it does. Then it doesn't again


Hello. I have a ROG Flow z13. As a preamble, I am extremely new to Linux and I’m trying to learn. I tried to fix this by downloading DisplayLink via Github. Did not work. I also tried on Wayland and Xorg.

I decided to get myself a hub for multiple, larger monitor support. First, I got a Daytona hub. Worked well. HDMI port worked.

Then I bought an another monitor, and decided to just buy a USB - C to HDMI converter and hook that to the hub. Turns out hubs USB-C ports don’t work for some reason. usbview returns nothing besides integrated USB-C ports.

Here’s the kicker, I can use two monitors if I plug it the USB-C to HDMI cable to the integrated port. The problem is one is a dedicated charge port and I don’t want to charge routing for the hub. So I bought a Baseus 11 port hub with two HDMI ports. The problem is, I only get vision on one monitor with the Baseus hub yet I know monitor gets input because it SOMETIMES works. When it does, it’s for one session, and most of the time the third monitor in system has broken visuals.

Thinking I can’t put two HDMI cables to one hub, finally I decided to buy a very small S-link HDMI to USB - C hub with one Power Distribution USB - C port and a USB - A port, thinking low number of ports wouldn’t cause much lose of power. I run into the exact same problem. It simply refuses to see two HDMI cables, unless it is a USB-C to HDMI cable that is connected directly to the PC.

What am I missing? Thank you in advance.

Added xorg and removed wayland

Maybe bandwidth limitations? Have you tested if it works if you set your displays to a lower resolution and/or refresh rate?

Not all USB-C ports support HDMI – you need ports that support “USB-C Alt Mode” and “full feature” USB-C cables. USB-C connectors that pass testing for DisplayPort over USB-C Alt Mode should have a DisplayPort (DP) logo. DisplayPort support enables HDMI, VGA, and DVI support using adapters.