Nvidia problems

I’ve recently installed Fedora Jam on my laptop and followed the instructions on rpmfusion.org to install Nvidia drivers. They seem to have been properly installed, but does not seem to be active. When using blender for instance I cannot select the GPU.

inxi -Fzx
  Kernel: 5.18.10-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: KDE Plasma v: 5.25.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: Micro-Star product: GL62 6QD v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-16J6 v: REV:1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: E16J6IMS.10C date: 01/17/2018
  ID-1: BAT1 charge: 34.6 Wh (90.1%) condition: 38.4/42.4 Wh (90.7%)
    volts: 11.9 min: 10.8 model: MSI Corp. MS-16J6 status: N/A
  Info: quad core model: Intel Core i5-6300HQ bits: 64 type: MCP
    arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 3007 high: 3026 min/max: 800/3200 cores: 1: 3001
    2: 3002 3: 3026 4: 3001 bogomips: 18399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915
    v: kernel arch: Gen9 bus-ID: 00:02.0
  Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Micro-Star MSI
    driver: nvidia v: 515.57 arch: Maxwell bus-ID: 01:00.0
  Device-3: Chicony USB 2.0 Webcam Device type: USB driver: uvcvideo
    bus-ID: 1-11:5
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.2 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.1.3
    direct render: Yes
  Device-1: Intel 100 Series/C230 Series Family HD Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 1-8.1:4
    bus-ID: 00:1f.3
  Device-2: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.10-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.54 running: yes
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet
    vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-10:3
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 931.51 GiB used: 86.95 GiB (9.3%)
  ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0
    size: 931.51 GiB
  ID-1: / size: 600.78 GiB used: 86.95 GiB (14.5%) fs: btrfs dev: /dev/sda2
  ID-1: swap-1 type: partition size: 18.45 GiB used: 0 KiB (0.0%)
    dev: /dev/sda6
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 44.0 C pch: 51.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 271 Uptime: 14h 24m Memory: 15.53 GiB used: 3.06 GiB (19.7%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 26
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19
glxinfo | egrep "OpenGL vendor|OpenGL renderer"OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics 530 (SKL GT2)
lsmod | grep -iE 'nvidia|nouveau'
nvidia_drm             73728  2
nvidia_modeset       1146880  2 nvidia_drm
nvidia_uvm           1286144  0
nvidia              40841216  82 nvidia_uvm,nvidia_modeset

I don’t know much about what all this means, but I’m hoping someone can help me out.

1 Like

You seem to have the drivers installed and loading properly.
You also seem to be running gnome on wayland.
With that config the nvidia dGPU is not normally active unless you explicitly select it when you open the app with a right-click and select to run the app with the discrete GPU.

If you wish to always use the nvidia gpu you may follow the instructions here

I always suggest that the edit done in step #8 adding the Option "PrimaryGPU" "yes" be done to both stanzas of that file to ensure that it operates correctly.

I also note that the nvidia gpu will only become primary and used full time if the user logs in with xorg and not wayland.

Finally, it seems that copying that file in even if you do not edit it is a good thing since it also makes other things on the system work better when running xorg with nvidia.

1 Like

Thank you. I followed the steps you linked to, but after rebooting after adding “PrimaryGPU” “yes” it just leads to a black screen. I entered my password just to try because I saw there was some hard drive activity and it seems to log me in, but only to a black screen. The only thing that’s visible is the mouse pointer and the corner indicator “light” when I move the mouse cursor there.

EDIT: I am on KDE and using Xorg.

Actually, I found I could press Ctrl+alt+T and open a terminal. But the window was only partial. Lacking borders and such. Used it to edit the file and remove the references to PrimaryGPU and rebooted to a working desktop. But the Nvidia GPU isn’t active.

You had not previously mentioned kde. That is an oversight that may have helped get a correct answer.

The nvidia.conf file does help with using the nvidia drivers when xorg is in use, but your inxi output clearly showed that you are using wayland.

Thus you have either switched to using an xorg login or are misunderstanding what DE is in use.

To use xorg instead of wayland simply use the gear icon at the lower left corner of the screen where you enter your password to log in and select xorg. The default for fedora 36 is wayland.

How do you know it is not active? Your post with the lsmod command showed the drivers were installed, and the inxi output showed the nvidia driver is in use for the nvidia GPU. Both imply that the GPU is actually active and waiting to be tasked.

Not active and not in use are different things

I did mention I had installed Fedora Jam which, I believe, is an official KDE spin- but I agree I should have been more specific, my apologies. I made sure I logged in to an Xorg session because I prefer using it at the moment. Besides when I tried Wayland it notified me the some Ibus thing wouldn’t work in Wayland. That notification didn’t appear in the xorg session. A recent update may have fixed that because when I tried logging in to Wayland now to double check that message didn’t appear anymore.

I “know” because when opening a project in the Godot game engine the debugger reports using the Intel chip. And blender runs slow and choppy on more complex scenes when I know it normally shouldn’t.

Thank you for taking the time to help me in any case.

ADDED: Oh, another indication is that the fan isn’t spinning up like it used to when under more demanding graphical processing. Trust me, this thing isn’t active.

I found this: https://discussion.fedoraproject.org/t/fedora-36-jam-spin-boots-to-black-screen-and-cursor/65076

Might be related. Perhaps I should just install Fedora 35 for the time being.