NVIDIA not working for kernel 6.5.7-300 for f39 beta

Hi. I am no expert, but here is what is happening to me. I installed fresh Fedora 39 beta, upgraded system that got me to kernel 6.5.7-300. Rebooted to that kernel. Followed Howto/NVIDIA - RPM Fusion to install NVIDIA driver, but it seems it has built akmods for 6.5.6-300. Now when I select 6.5.7 in boot menu, I get message during boot: “​Nvidia kernel module missing, falling back to nouveau”. Also when I boot to 6.5.7, delete kmod-nvidia-6.5.6-300.fc39.x86_64-3:535.113.01-1.fc39.x86_64 and run sudo akmods --force, I still get 6.5.6 version. Is there something I can do to be on 6.5.7 and have nvidia working? Thanks a lot

Thank you for testing the beta release. You could report your findings to the fedora test mailing list.

However if you just want a working system install f38 and wait for f39 to be released then upgrade to it.

1 Like

im running akmods nvidia with 6.5.7-200.fc38.x86_64 now on F38, but F39 Beta works fine still.

have you tried sudo dnf remove 'kmod-nvidia-*' and then sudo akmods --force

Yes, I did, as written in my op. Was on 6.5.7., deleted kmod-nvidia-6.5.6, run akmods --force and I again got kmod-nvidia-6.5.6

Did you install kernel-devel-6.5.7-200.fc38.x86_64, kernel-modules-6.5.7-200.fc38.x86_64,and kernel-modules-extra-6.5.7-200.fc38.x86_64?

1 Like

You can check the log files located at /var/log/akmods to see if there were any build problems. Any error can be reported to https://bugzilla.rpmfusion.org/ which is the bug list for rpmfusion.

Have you tried this
dnf update --enablerepo=updates-testing,updates
As far as I know Fedora39 is frozen until the final release and kernel-devel is needed to build akmods.The latest kernel-devel is not in Fedora39 yet until the final release.

1 Like

When I upgraded to F39 then wanted the 6.5.7 kernel I already had the akmod-nvidia package installed with the 6.5.6 kernel.

I performed the additional kernel upgrade with dnf upgrade --enablerepo updates-testing and it automatically pulled in the kernel-devel package for the 6.5.7 kernel.

If you do not have the kernel-devel package installed for the 6.5.7 kernel then repeat the upgrade with dnf upgrade kernel-devel --enablerepo updates-testing and it should then pull in the newer kernel-devel package which is mandatory to build the nvidia driver for the 6.5.7 kernel.

You can see what kernel-devel packages are already installed with dnf list installed kernel-devel.

1 Like

Thank you guys. kernel-devel was indeed the problem. dnf upgrade --enablerepo updates-testing this solved the problem. I am now on 6.5.8 and nvidia is working. Now I have problem that I cant open Google Chrome on wayland, but I can do with X11 just fine for now.

And I also want to say that I am super grateful for how helpful you guys have been. What a nice community. I was using archlinux before and every time I asked something on forum, I only got sarcasm and laughter that I don’t know everything like they do without any help. You guys are the best :+1:


same problem, driver installed and works, but some apps like vscode and chrome are transparent

Different problem
Please open your own thread.