NVIDIA GPU Fails to power off (PRIME) Razer Blade 14 2022

I’ve installed Fedora 37 WorkStation KDE on my Razer Blade 14 2022 and have followed the documentation to enable RPM fusion and install the nvidia driver, and everything is up to date and appears installed properly.

The NVIDIA GPU is able to power off into D3cold status according to cat /sys/class/drm/card*/device/power_state when on AC, but on battery it switches to D0. I would like it to power off and run in D3cold all the time unless prompted to turn on by an application in order to save battery life. I have verified that D3cold works on battery in ubuntu, so it seems to be a matter of proper software configuration.

Please help me set it up so the NVIDIA GPU is powered off on battery! Thanks :slight_smile:

1 Like

I have the same laptop and the same problem on Fedora 38. On 37 it worked fine following this guide but now it goes from being in D0 for a while to D3hot to D3cold and then immediately back to D0 on battery (works as expected when charging though, as you mentioned). Maybe you’ll have more luck following that guide, I’ll try to debug more and report back!

Edit: Also I think with nouveau D3cold works as expected but that’s not really helpful if you need nvidia drivers.

What is the status of nvidia-powerd? systemctl status nvidia-powerd.service

Here’s the output.

○ nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; disabled; preset: disabled)
     Active: inactive (dead)

I have tried enabling it and restarting but it didn’t seem to make any difference. When it was enabled it didn’t show any error messages.

Thank you for the suggestion. The behavior you describe is very similar to that of my device. I will try that guide at some point and report the results here. I am relieved to hear that I am not the only one with this problem (although I am sorry you are also experiencing it).

A bug has been filed here on the nvidia developer forums. Something else I’ve noticed is that this issue did not occur on on or before nvidia driver version 525.85.05, but the versions after that are broken for me with regards to this issue. Perhaps this is why it worked for you on fedora 37 but not 38? For now I am just using envycontrol to switch to integrated-only mode when I need battery life, but I would much prefer to have this issue resolved eventually so I can use hybrid mode as intended.