NTFS Partition with Write Permissions on Fedora Permanently

Hai…

Is there any way to make ntfs partition mounted permanently and get read and write permissions always on fedora…?

They already have a good explanation how to do it kindly go through it.

2 Likes

Thank you…

hi…

It worked…
but i have another issue…the issue is ownership. it is still have root user ownership… but when i am trying to change the user and group ownership to another user it shows like it changed without no errors and but after when i checked it still in root ownership…

Ownership is very important for me now because i am working on VM’s…so i want to store my VM storage pool’s to this ntfs disk rather than default directory…

If you have a another issue kindly create a new post so others can also look into it for a better possible solve and not only that other users when in future they encounter the same issue they can find it with a simple search i hope you don’t mind and understand this is how askfedora works.

For non-POSIX filesystems, the file ownership is also set by mount options.

This means that all files will have the same ownership.

In general, unless you are storing something like media(documents/videos/music/etc), a non-POSIX filesystem is a terrible place to store data on Linux.

It is worth noting that although it is rarely used and more of an advanced topic it is possible to enable map ntfs ACLs to Linux permissions/ownership.

1 Like

ok no problem…

Hi…

The issue is about ownership of NTFS partition mount point… it had root user ownership… but when i am trying to change the user and group ownership to another user it shows like it changed without no errors and but after when i checked it still in root ownership…

Ownership is very important for me now because i am working on VM’s…so i want to store my VM storage pool’s to this ntfs disk rather than default directory…

I know someone asked you to create a separate topic but this is basically an extension of the same question so I merged them back together as a single topic.

See my responses above. That being said, I am not sure it will be easy to store libvirt’s vm files on an ntfs filesystem. I don’t know if it can store the SELinux contexts.

1 Like

yeah but first my issue is about ownership of that ntfs mount point…

It is, of course, very subjective but ownership and permissions are basically both part of permissions. The two questions are both about setting permissions on the same ntfs partition.

The context from this topic will help readers understand the situation better.

1 Like

It is me you know my name please don’t call me someone and i still think this should be a another topic as it was another issue and maybe it seems like a extension but it isn’t

If you’re using kernel 5.15 you could change the filesystem in the fstab from ntfs to ntfs3. With ntfs3 you will using driver from Paragon that recently merged to linux kernel instead of ntfs-3g driver.

With Paragon driver, you could easily change the owner and group file name. But I’m not sure if it could save vm image file and access it.

Also maybe you can play with parameter like defaults,users,exec or something else.

1 Like

ok it worked as you said it changed the ownership with ntfs3 & i am happy with that…

But same permission denied error getting in VMs whiile creating VM…

As you said… :point_down:
But I’m not sure if it could save vm image file and access it…

So i am thinking to create another partition with ext4 fs and then do my job…

or
Is it there any other solution have you may suggest me for…

sorry for my English. :blush:

yeah…

I’m sorry, I only use my home dir to make sure everything just works. For other partitions I use for archiving data only and not as working directories.

My English also not only bad, but very broken. :sweat_smile:

For the root ownership I assume you switched to root before doing your “chown”. That can not fail to work unless the “sticky bit” has been applied to the directory, which you caneasily tell by ls’ing them directory and get something like drwdr-xr-xt (note the “t” at the end of the permissions, it means that the file can be removed by resetting the directory. I’m not quite sure how that works, but those bits are in binary, rather than octal. Setting the permissions to “0777” will either have no effect or remove the “directory bit”.

It might be 001755, where the “0” preceeding the “1” might be the "sticky bit. The sticky bit that means “store this on the swap device” might be the bit before the proposed “sticky bit”, but again, I’m not sure enough to try it myself.

I’ve seen maps that look something like "-Ttdrwxrwxrwx, where the capital T is the one that means “store this on the swap device”. It also comes at the end of the permissions as depicted customarily in Unix/Linux. rwxr-xr–T might be one example.

Maybe you knew that already, I’m just learning about it.

I don’t know much about Windows “acl”'s, except that they are supposed to be infuriating. I’d like to learn more about them for Samba (there’s a Samba instruction in smb.conf that asks “inherit acls”? And I always say no because of my faulty knowledge of Windows. In my opinion,Windows itself is faulty, from Windows 2.0 to Windows 11, I’ve seen them all. It doesn’t trust mere users to do anything except “run as Administrator” for certain programs.

But I rant again, forgive me. I’ll try not to do it again.

BryGuy

Sometimes it is better to click on cancel instead of replay. Especially in topics with a solution.

I found your issue friend. I installed Fedora 40 in KDE and refollowed your steps exactly, and when I mounted the drive, it said that it was unclean and would therefore only mount read only.
This is the part you got to be careful of. Because it is not just a plain folder it needs to be managed by root. The owner and all that SHOULD BE ROOT. So dont change that part, because it is linked and managed by the OS, leave that part alone.

The fix you need would be this:
from the console, type:
sudo ntfsfix /dev/sdb <— (Or change sdb to whatever your SATA controller is labeling your hard drive)

This should have been included in the guide, but it was left out. So its here now. Virtually every NTFS drive from a windows dual boot will be “dirty” and need ntfsfix to clean before linux can use it with read and write permissions.

Just restart your PC and after that, it will then mount from FSTAB cleanly and with read and write permissions from the guide after that.