No signal using Displayport since kernel 6.7

I use Displayport for connecting my display to my desktop computer. There were no problems when using the 6.6 kernel, but when I installed the first available 6.7 kernel and tried booting I could not see anything after the motherboard boot logo, only a black screen. I tried rebooting from the black screen using the computer case buttons which made the GRUB kernel selection screen visible, but as soon as I select a 6.7 kernel there is only a black screen. If I reboot and select the last 6.6 kernel everything works as usual.

After some troubleshooting I noticed that if I use HDMI instead of Displayport I can boot into the 6.7 kernels as well and everything seems to work normally. If I try switching to Displayport while logged in the black screen reappears until I switch back to HDMI.

How can I fix this? I need to use Displayport since the high refresh rates I use are unsupported by my hardware through HDMI.

Some specs: Fedora 39, KDE spin, all latest updates installed, Intel 12600K CPU with UHD 770 integrated graphics for the monitor

I suspect you really mean want and not need.
Using ‘need’ tends to imply you have no choice, while ‘want’ indicates a preference. You just said that you can use hdmi instead of DP so that implies a preference.

You did not give us any information about the hardware, nor up to date details about the OS.

Please post the output of xrandr and inxi -Fzxx so we may see more details of the hardware and software installed. Use the </> button on the toolbar to retain the formatting you see on your screen and keep it more readable for us so we may assist in troubleshooting.

Correct, I mean that I want to use Displayport since HDMI gives me an inferior experience. I apologize if it was unclear, English is not my native language.

Here is the output of xrandr:

# xrandr
Screen 0: minimum 16 x 16, current 3840 x 2160, maximum 32767 x 32767
DP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 640mm x 360mm
   3840x2160    143.84*+
   2048x1536    143.78  
   1920x1440    143.81  
   1600x1200    143.72  
   1440x1080    143.69  
   1400x1050    143.78  
   1280x1024    143.67  
   1280x960     143.73  
   1152x864     143.75  
   1024x768     143.66  
   800x600      143.48  
   640x480      143.30  
   320x240      142.05  
   2560x1600    143.80  
   1920x1200    143.74  
   1680x1050    143.79  
   1440x900     143.73  
   1280x800     143.84  
   1152x720     143.57  
   960x600      143.72  
   928x580      143.50  
   800x500      143.25  
   768x480      143.69  
   720x480      143.35  
   640x400      143.37  
   320x200      141.40  
   3200x1800    143.84  
   2880x1620    143.81  
   2560x1440    143.83  
   2048x1152    143.74  
   1920x1080    143.72  
   1600x900     143.69  
   1368x768     143.61  
   1280x720     143.67  
   1024x576     143.62  
   864x486      143.23  
   720x400      143.29  
   640x350      143.57

Here is the output of inxi -Fzxx using the 6.6.14 kernel that works correctly. I replaced the LUKS ID at mapped on partition ID-1 and ID-4 with xxx since I do not know if this is sensitive information or not (probably not, but better safe than sorry):

# inxi -Fzxx
  Kernel: 6.6.14-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 39 (KDE Plasma)
  Type: Desktop Mobo: Gigabyte model: Z690 GAMING X DDR4 v: x.x serial: N/A
    UEFI: American Megatrends LLC. v: F24a date: 05/31/2023
  Info: 10-core (6-mt/4-st) model: 12th Gen Intel Core i5-12600K bits: 64
    type: MST AMCP arch: Alder Lake rev: 2 cache: L1: 864 KiB L2: 9.5 MiB
    L3: 20 MiB
  Speed (MHz): avg: 799 high: 801 min/max: 800/4900:3600 cores: 1: 800
    2: 800 3: 800 4: 800 5: 792 6: 800 7: 800 8: 801 9: 800 10: 800 11: 801
    12: 801 13: 800 14: 800 15: 800 16: 800 bogomips: 117964
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel AlderLake-S GT1 vendor: Gigabyte driver: i915 v: kernel
    ports: active: DP-1 empty: HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:4680
  Display: wayland server: v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: DP-1 res: 1920x1080 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: iris device: 1 drv: swrast
    surfaceless: drv: iris wayland: drv: iris x11: drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.5 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics 770 (ADL-S GT1)
    device-ID: 8086:4680 display-ID: :0.0
  API: Vulkan v: 1.3.268 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: mesa intel device-ID: 8086:4680 device: 1
    type: cpu driver: mesa llvmpipe device-ID: 10005:0000
  Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:7ad0
  API: ALSA v: k6.6.14-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8125
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 465.76 GiB used: 50.77 GiB (10.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 500GB
    size: 465.76 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 30.9 C
  ID-1: / size: 464.16 GiB used: 50.43 GiB (10.9%) fs: btrfs dev: /dev/dm-0
    mapped: luks-xxx
  ID-2: /boot size: 973.4 MiB used: 298 MiB (30.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 51 MiB (8.5%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 464.16 GiB used: 50.43 GiB (10.9%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-xxx
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 29.0 C mobo: 25.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.39 GiB used: 7.35 GiB (47.7%)
    igpu: 60 MiB
  Processes: 558 Power: uptime: 2h 4m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: Compilers: gcc: 13.2.1 Shell: Bash v: 5.2.26 running-in: konsole
    inxi: 3.3.32

The xrandr output seems to indicate that you are using 3840x2160 resolution at 144 Hz. The inxi output though shows 1920x1080 resolution

Both indicate using DP output.

Have you used the kde settings → display panel to check the actual config that is set for that monitor? The inconsistency in reported resolution may be a result of not properly setting up the display in settings.

Have you verified the refresh rate for the monitor?

My laptop works very well with a refresh at 144 Hz even when I have an external monitor attached with 60 Hz refresh.

xrandr is correct, I am using 3840x2160 at 144 Hz. inxi is incorrect (though I assume you mean 1920, not 1960), I am not using (and have never used) that resolution.

Correct, as I previously mentioned I want to use DP since HDMI does not give me the refresh rate I want, HDMI only gives me 3840x2160 at 60 Hz. This is in fact what happens when I boot a 6.7 kernel using HDMI.

I assume you mean the settings in KDE, not Gnome. If I go to Display and Monitor in System Settings, I see the correct name of the monitor and the correct values of 3840x2160 at 144 Hz. If I do the same using HDMI and kernel 6.7, I instead see 3840x2160 at 60 Hz as expected (and I cannot change it to higher than 60 Hz since my hardware does not support it).

I am 100 percent sure that the monitor is currently (and has always been) operating at 144 Hz on DP. However, I have not formally verified this using a specific method if that is what you mean. If you think this is needed to troubleshoot my problem I can certainly do so, please tell me how in that case.

I have only one display attached and it has always used 3840x2160 at 144 Hz through DP before kernel 6.7.

This sounds like it may be a limitation of the hdmi interface and not the software. You see the monitor at 144 Hz with DP but only at 60 Hz with HDMI. An interface can never perform better than its physical limitations.

If I understand your dilemma properly it seems that hdmi may have previously functioned at 144 Hz, but now only functions at 60 Hz. Is that correct?

If so then this may be a regression in the kernel or drivers and possibly should be reported as such with a bug report at

Yes, as I previously mentioned, my hardware does not support the high refresh rate I use through HDMI. That is why I use DP since it works with 144 Hz.

No, that is incorrect. HDMI has always only functioned at 60 Hz (or lower) using 3840x2160. That is the reason why I have not used HDMI before, only now for troubleshooting. My problem is that DP does not work at all after installing kernel 6.7, now I only get a black screen after the motherboard boot logo, nothing else (except for the GRUB kernel selection screen if I reboot). The only functioning way to boot into Fedora using DP is to use the last 6.6 kernel I still have, otherwise if I use a 6.7 kernel I can only use HDMI. As I only get 60 Hz from HDMI it is not a good solution since I want to use 144 Hz which is only supported by DP on my hardware. In summary: Using kernel 6.6 and earlier, DP works as expected. Using kernel 6.7, DP does not work.

If it worked as expected with the 6.6 kernel and does not work the same with the 6.7 kernel then I definitely recommend that you file a bug report due to the regression.