No more grub (and Fedora access) after updating Linux Mint


new Linux user here!
I have an older PC who used to have Windows XP…
I have 2 ssd in this PC, on the first one I installed Linux Mint 20.3, after that on the other one i installed Fedora 36.

After installing Fedora 36, each time I rebooted i had grub menu with both Fedora (main Linux) and Linux Mint (backup Linux in case something does not work in Fedora).
Yesterday i upgraded Linux Mint from 20.3 to 21, that upgrade was successful, but since the upgrade i no longer have the Grub menu, computer boot directly to Linux Mint, and if i run grub-customizer it only shows Linux Mint, i cannot see my Fedora.

What I did so far:

  • Run “grub-mkconfig”, doesn’t do anything
  • Run lsblk, i see my disk and partition where Fedora is installed (in my case sdb3).
  • I tried to boot on the Fedora usb i used to install my system, run grub-customizer from there but same result.

What can i do to have my grub and fedora back??


1 Like

do sudo update-grub in linux mint and then see if fedora appears in grub.

Boot into Fedora, if necessary via a live USB, or simply boot into your Mint installation.

From there, then chroot into your installed Fedora on the other internal drive.
Next, re-install and update Grub2 the Fedora way.
Exit from chroot, and reboot.

You will have to do that in the future, whenever Grub receives an update in Mint, so it would be good to learn the procedure.

Are both internal linux drives mounted via /etc/fstab in both distributions?
If so, you can disable Grub’s os-prober in the Mint distribution, and in the future only update your Grub2 configuration from within Fedora. Os-prober should be enabled in Fedora for this strategy.

You should not (strongly discouraged) use grub-customizer, as it will surely mess up your grub-config during future updates.

I think Linuxmint’s os-prober is the culprit here. I would try, on Mint, to first run sudo os-prober. That will, hopefully, show Fedora, and from there, follow martin luthor’s advice and do sudo update-grub (again on Mint.) Or, use ivanhoe’s method, depending upon which distribution’s grub you want to do the booting. On any multiboot system, you’ll have to do this whenever upgrading any of the distributions on it. Not sure about any systems added to custom.cfg. For example, I have a custom.cfg for FreeBSD, and that doesn’t get affected by any updates, either to the FreeBSD install or any of the Linux distributions on it.

Another possible solution, assuming it’s using UEFI is rEFIfind. The rEFInd Boot Manager
I’ve not used it but someone on Fedora forums swears by it. (I don’t know if it requires any configuration after updates.)

Hi ivanhoe,

first, i found a workaround to boot in my Fedora linux. During PC startup, i can go in BIOS an select “boot from”, and then i see a line that says Fedora. If i select Fedora i see the grub menu i used to have with both Linux Mint and Fedora, and if i choose Fedora my Fedora launch without any problem.

In another reply i was told to try sudo os-prober. I tried in both Mint and Fedora, in both case i have the same message:
grub2-probe: error : cannot find a GRUB drive for /dev/sdd3. Check your

So i can access my Fedora but it’s not practical at all.
I’m looking at the documentation to see how to reinstall GRUB from Fedora.


Not the way i intended to do it, but that worked.
I went to my Bios, changed the boot order, default boot Fedora.
And when booting on Fedora i have the option Fedora or Mint.

So it’s working that way, that’s good enough for me!
Thanks for your answers, i will continue to test and improve in my Linux knowledge.

1 Like

One can never stop learning…
Happy you found a solution!


I had the same problem on a Dell Optiplex Desktop with legacy bios A15.

Considering what I just went through your circumstance seemed non destructive and had a solution to the problem. I also was locked out of the grub menu to choose an operating system to boot into. In my bios setup there is no option to change a hard drive “boot from”. The only option was boot from sata, usb, or cd/dvd. I was unable to get anything working. Attempted to use a usb live version of Mint 20.3 and the repair boot option application. That did nothing to change the problem.

Tried from a live usb version of Fedora Workstation 36 and Mint 20.3 to get into the grub.config of Fedora file (the top grub chainloader file for a menu of operating systems to choose) an possibly make changes to the menu. Was able to get to the file yet found myself locked out of the file when attempting to open, something I am able to do when inside the Fedora operating system using a sudo/root password or first changing the chmod permissions through a terminal to save any changes. Seems this inability to get into the grub.cfg file is a good security safeguard from unwanted intrusions, yet for my situation and problem lead to disaster.

In the end I had to delete both partitions and fresh re-install the operating systems that were on this computer before the attempt to upgrade to Mint 21. Unusual circumstance with Mint upgrade, the process and procedure went fine and seemed complete with no problems, everything was installed yet no bootloader menu after computer restart. After I was locked out entirely with no boot menu I attempted to use a live usb version of Mint 21 for either repair or to re-install since the upgrade caused this problem.
The Mint 21 usb live version would not even work on this computer, whereas a computer not so old it did work. I believe the computer I attempted to upgrade to Mint 21 has some problems with a legacy bios, in particular the A-15 version on this Dell.

If i had to reinstall my OS, i would be sure to reinstall Mint first then Fedora, because that what i did the first time and installing Fedora last allowed me to have the grub with both options.
Problem seems to happen after a Mint install/upgrade, and i don’t know why since my knowledge of Linux is still very limited.

What i know is little by little my Fedora is becoming more and more usable and i’m about to replace Windows completely.
And i love it :stuck_out_tongue:


The last grub installed has control of booting, thus a difference between mint and fedora could cause that issue.

I agree with installing fedora last (or at least booting to the live media then doing a chroot grub reconfig so it takes control of the boot grub.)

I did not note, or did not say, but hopefully you are using uefi boot since legacy boot has some issues with multiple OSes booting.

1 Like