No HDMI Audio output shown for my TV When I Plug HDMI in!

hello, I am using helvum and pulseaudio volume control. Whne I plug in my TV through hdmi I get no sound Output from the TV. PulseAudioVoulme Control shows my TV is playing sound but Helvum shows nothing.

Check with alsamixer and then press F6 select HDMI. After that press F3 for Playback. If you see [MM] means it currently muted. You can unmute it by pressing m on your keyboard.

I just tested if we mute HDMI playback from alsamixer, from the pavocontrol will still give impression that the sound are not muted.

You also may not have the correct output device selected in gnome settings → sound

HDMI NOT listed. I’ll tell u my user background. I’m new to linux but hdmi worked fine in Windows

When you press F6, what the cards listed there?

Or you can run aplay -l (lowercase L) from terminal and post it here.

     Discard all samples (playback) or generate zero samples (capture)
     PipeWire Sound Server
     Default ALSA Output (currently PipeWire Media Server)
     HDA Intel PCH, ALC3227 Analog
     Default Audio Device
     HDA Intel PCH, ALC3227 Analog
     Front output / input
     HDA Intel PCH, ALC3227 Analog
     2.1 Surround output to Front and Subwoofer speakers
     HDA Intel PCH, ALC3227 Analog
     4.0 Surround output to Front and Rear speakers
     HDA Intel PCH, ALC3227 Analog
     4.1 Surround output to Front, Rear and Subwoofer speakers
     HDA Intel PCH, ALC3227 Analog
     5.0 Surround output to Front, Center and Rear speakers
     HDA Intel PCH, ALC3227 Analog
     5.1 Surround output to Front, Center, Rear and Subwoofer speakers
     HDA Intel PCH, ALC3227 Analog
     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
     HDA Intel PCH, HDMI 0
     HDMI Audio Output
     HDA Intel PCH, HDMI 1
     HDMI Audio Output
     HDA Intel PCH, HDMI 2
     HDMI Audio Output
     HDA Intel PCH, HDMI 3
     HDMI Audio Output
     HDA Intel PCH, HDMI 4
     HDMI Audio Output

I understand now. Your internal speaker & HDMI are in the same mixer “HDA Intel PCH” and not separated. From your print screen of alsamixer, your HDMI are presented with S/PDIF that on the mixer only have ability to mute/unmute. That also explain your Helvum that not showing HDMI name instead it’s showing HDA Intel PCH.

For test, from aplay -l above, you can see the card 0: ..., device 3: HDMI .... You can test for each of them with speaker-test -D hw:CardNumb,DeviceNumb -c 2 -l 1. For example for [HDMI 0], you can run speaker-test -D hw:0,3 -c 2 -l 1. Take a note which hw:card,device give a noise sound.

1 Like

Please post all text copied from your screen using the </> Preformatted text tags above. It gives a result identical to what is seen on your screen and makes it much easier for us to read and analyze.

Note that I edited your post above to include the tags and that it now looks much closer to the original on your screen.

Also, when posting screen output it is polite to include the command line at the beginning so there is no ambiguity about what command produced that result.

Thank you.

I see 5 HDMI devices listed there, so it should be possible to select the hdmi output from within gnome settings → sound and have it work for you.

From @computersavvy above, it also possible that after you select your card, right bellow the “Output Device”, there should be a “Configuration”. If it present, select accordingly since possibly your “Output Device” only showing one option like alsamixer above.

Hi all,

I have been experiencing the same issue. The internal speaker & HDMI are in the same “HDA Intel PCH” mixer.

Although when running speaker-test -D hw:0,3 -c 2 -l 1, I manage to get the noise sound from the HDMI, but when lanunching new applications, there is no output audio.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX8200 Analog [CX8200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

@red093 Hi, you could try to follow this steps but with bellow conf:

    { factory = adapter
        args = {
             = api.alsa.pcm.sink
                = "HDMI 3"
            node.description       = "HDMI on device 3"
            media.class            = "Audio/Sink"
            api.alsa.path          = "hw:0,3"
            audio.channels         = 2
            audio.position         = "FL,FR"

After following the steps from the link above, you should get “HDMI 3” from Gnome Settings.

1 Like

HDMI Audio is also an intermittent problem for me, sometimes it works, sometimes it does not.

The HDMI video is displayed but the audio sometimes does not work.

Disconnecting the HDMI cable and reconnecting it sometimes restores the audio.

The are so many software and hardware components involved that it is difficult to identify the problem source.

HI @oprizal ,

Thank you very much for your suggestion.

I was able to follow your steps, and indeed I have now HDMI 3 shown as an option in Gnome Settings

Nevertheless, I am not able to obtain any HDMI sound when the option is selected.

Some other details that might been interesting for understanding the root cause.

When running speaker-test -D hw:0,3 -c 2 -l 1,, I can only obtain the noise test sound if the command is run after restarting fedora or when running

systemctl --user restart pipewire
systemctl --user restart wireplumber

When selecting the HDMI 3 option in Gnome Settings as output, or when using any other app that requires access to the system audio before running speaker-test -D hw:0,3 -c 2 -l 1,, the message I get from terminal is ‘resource busy’.

What do you think might be happening here? it looks like the resource is being used but not from the system audio.

Many thanks,


Hi @bebopspeaks ,

Thank you very much for your reply.

Indeed, trying to understand the root cause might be challenging here.

However, I can confirm this is not an hardware related issue since I get everything working smoothly on Linux Mint when using the same laptop, with the same HDMI cable, and the same TV screen.

I think there might be a mishadling of processes from pipewire that is causing this, but this is just a gut feeling.

Many thanks,


Close any/all windows except the terminal then wait a moment and try again with speaker-test. Or logout then login again but don’t open anything except the terminal.

First, if you read the config above, you’ll see parts:

            api.alsa.path          = "hw:0,3"
            audio.channels         = 2

It’s same as -D hw:0,3 and -c 2 from speaker-test respectively.

Means it only work with one of five HDMI ports you have. If you change the HDMI port, most likely it will not work.

It might be a software and hardware interaction though…

I replaced ‘pipewire’ with ‘pulseaudio’ and the loss of audio continues.

Reliably reproduce the loss of audio problem by switching from HDMI Stereo to HDMI 5.1 Surround.

Switching back to HDMI Stereo does not restore the audio.

This makes me suspect an interaction between the software and HDCP (high definition copy protection) but maybe I’m just paranoid.

The software thinks it is talking to HDMI but the hardware is not passing it on (?)

Hi @oprizal,

Thank you very much for your reply.

I made sure the config file had the same values as the speaker test parameters, but still no luck.

Weirdly enough, Fedora thinks I have 5 HDMI ports, whereas I only have one in my x1 carbon :slight_smile:

Many thanks,