HDMI Audio and Mic broken

I have recently installed F34 on a new Razer Blade 14 (laptop) machine with an NVIDIA 3060 GPU and AMD CPU. So far I have manged to install the Nvidia drivers from rpm fusion, and make the dGPU the primary GPU. The laptop screen runs fine off the GPU, as well as the HDMI video, however HDMI audio is not working (as far as I know the HDMI port is directly connected to the dGPU). The internal laptop speakers are working, but they may be running off the CPU’s internal GPU.

Hoping someone has some ideas on what to do here. Here are some screenshots of various things to give you an idea of what I am working with.

Here is the file /etc/X11/xorg.conf.d/nvidia.conf (against the file’s wishes, I edited it and put the

Option "PrimaryGPU" "yes"

lines in there)

  1 #This file is provided by xorg-x11-drv-nvidia
  2 #Do not edit
  4 Section "OutputClass"
  5     Identifier "nvidia"
  6     MatchDriver "nvidia-drm"
  7     Driver "nvidia"
  8     Option "AllowEmptyInitialConfiguration"
  9     Option "SLI" "Auto"
 10     Option "BaseMosaic" "on"
 11     Option "PrimaryGPU" "yes"
 12 EndSection
 14 Section "ServerLayout"
 15     Identifier "layout"
 16     Option "AllowNVIDIAGPUScreens"
 17     Option "PrimaryGPU" "yes"
 18 EndSection

The output of
lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne (rev c4)

The output of
lspci | grep Audio

01:00.1 Audio device: NVIDIA Corporation Device 228e (rev a1)
04:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor (rev 01)
04:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller

Here is a screen shot of the Nvidia driver settings screen

I would post more screen shots of the pulse audio settings while the HDMI video out is working, however I can only embed one screenshot. Under Output Devices on the Pulse Audio Settings it only lists “Family 17h HD Audio Controller Speaker + Headphones,” and under configuration it does list, “HDA NVidia,” however it cannot be changed from the “Off” position (there is no other option).

Please let me know if there is any more information I can provide to help get this issue resolved!

Just would really like the mic and audio out to work!

Thanks so much for your time!

Please attach the output of “inxi -Fxx” (in code tags please) so we can see all the details of the hardware and drivers that are running.

By code tag do you mean the three " ` "?

Here is the output of

inxi -Fxx

System:    Host: fedora Kernel: 5.12.15-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35.1-41.fc34 
           Desktop: GNOME 40.2 tk: GTK 3.24.30 wm: gnome-shell dm: GDM Distro: Fedora release 34 (Thirty Four) 
Machine:   Type: Laptop System: Razer product: Blade 14 - RZ09-0370 v: 1.04 serial: <superuser required> Chassis: 
           type: 10 serial: <superuser required> 
           Mobo: Razer model: PI411 v: 4 serial: <superuser required> UEFI: Razer v: 1.05 date: 06/01/2021 
Battery:   ID-1: BAT0 charge: 33.8 Wh (53.4%) condition: 63.3/61.6 Wh (102.6%) volts: 15.2 min: 15.4 
           model: Razer Blade serial: CNB1RC30-037016700508-A01 status: Discharging 
CPU:       Info: 8-Core model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3 rev: 0 
           cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 105400 
           Speed: 1197 MHz min/max: 1200/3300 MHz boost: enabled Core speeds (MHz): 1: 1197 2: 3093 3: 1197 4: 1198 
           5: 1538 6: 1459 7: 1396 8: 1397 9: 1197 10: 1197 11: 1197 12: 1197 13: 1197 14: 1197 15: 1467 16: 1397 
Graphics:  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Razer USA driver: nvidia v: 465.31 
           bus-ID: 01:00.0 chip-ID: 10de:2520 
           Device-2: Advanced Micro Devices [AMD/ATI] Cezanne vendor: Razer USA driver: amdgpu v: kernel 
           bus-ID: 04:00.0 chip-ID: 1002:1638 
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 3-4:2 chip-ID: 13d3:56d5 
           Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: loaded: amdgpu,ati,nvidia 
           unloaded: fbdev,modesetting,nouveau,vesa alternate: nv resolution: 1920x1080~144Hz s-dpi: 96 
           OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes 
Audio:     Device-1: NVIDIA vendor: Razer USA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:228e 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Razer USA 
           driver: snd_rn_pci_acp3x v: kernel bus-ID: 04:00.5 chip-ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Razer USA driver: snd_hda_intel 
           v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 
           Sound Server-1: ALSA v: k5.12.15-300.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel port: f000 bus-ID: 02:00.0 
           chip-ID: 8086:2725 
           IF: wlp2s0 state: up mac: 80:45:dd:6f:a4:a5 
           IF-ID-1: virbr0 state: down mac: 52:54:00:de:4f:c1 
Bluetooth: Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-3:2 chip-ID: 8087:0032 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 953.87 GiB used: 8.11 GiB (0.9%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HBLR-00000 size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 
           serial: S4GJNX0R221775 
Partition: ID-1: / size: 788.69 GiB used: 7.85 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p7 
           ID-2: /boot size: 975.9 MiB used: 208 MiB (21.3%) fs: ext4 dev: /dev/nvme0n1p6 
           ID-3: /boot/efi size: 96 MiB used: 59.8 MiB (62.3%) fs: vfat dev: /dev/nvme0n1p2 
           ID-4: /home size: 788.69 GiB used: 7.85 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p7 
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 406 Uptime: 3h 43m Memory: 15.1 GiB used: 3.21 GiB (21.2%) Init: systemd v: 248 runlevel: 5 
           target: graphical.target Compilers: gcc: 11.1.1 Packages: rpm: 2317 Shell: Bash v: 5.1.0 
           running-in: gnome-terminal inxi: 3.3.03 

I had never used the audio on my monitor since it only has a speaker jack, so to see what my system would do using it I tried it.

At first I could only get a very soft output from the speaker test even with the volume turned up. Investigating the monitor config I found a volume control in the menus there that was set to 25%. I also found a mute option.

After resetting the monitor volume to 85% and ensuring it was not muted I had good sound via the hdmi channel.

Maybe you should check the monitor itself for a setting that blocks audio through the hdmi port. (That may or may not be possible on the laptop, although you are talking about an external monitor as well.)

BTW, you are aware that F34 uses pipewire and not pulseaudio are you not? Setting things within pulse audio configs will not assist in configuring pipewire.

I use the gnome settings → sound panel to set most of what I do and have few problems (other than the external configs like the setting on the monitor itself).

I am confident that the monitor has a loud enough volume since I can plug into it with my Chromebook and the Audio and Video work fine.

I misspoke when I said pulse audio. I was referring to the pavucontrol app which is where all the settings for audio output/input can be found. Sorry about the confusion!

I am still thinking that the problem is with the GPU since the mic is also not working which I believe is also controlled by the GPU. Any other ideas?

sudo dnf swap - -allowerasing pipewire-pulseaudio pulseaudio
rebooting, then
sudo dnf swap --allowerasing pulseaudio pipewire-pulseaudio
and rebooting again got my microphone working. However, HDMI audio out is still not working at all.

I also just tested the headphone jack, and audio is extremely faint. If I turn up volume settings past 100% the sound gets a little louder but distorted. The headphones are essentially unusable either way.

Using a USB C jack as headphone output works well

Fortunately (or not) the general trend today is moving toward everything USB. That seems to leave the standard everyday things as second nature and less supported.

I really don’t understand that since most mobos today have built in audio and the trend should be to support those chipsets, then add the USB as well.

Here is some additional info

[me@fedora: ~]$ aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    PipeWire Sound Server
    Default ALSA Output (currently PipeWire Media Server)
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 1
    HDMI Audio Output
    HDA NVidia, HDMI 2
    HDMI Audio Output
    HDA NVidia, HDMI 3
    HDMI Audio Output
    HDA NVidia, HDMI 4
    HDMI Audio Output
    HDA NVidia, HDMI 5
    HDMI Audio Output
    HD-Audio Generic, ALC897 Analog
    Default Audio Device
    HD-Audio Generic, ALC897 Analog
    Front output / input
    HD-Audio Generic, ALC897 Analog
    2.1 Surround output to Front and Subwoofer speakers
    HD-Audio Generic, ALC897 Analog
    4.0 Surround output to Front and Rear speakers
    HD-Audio Generic, ALC897 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HD-Audio Generic, ALC897 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HD-Audio Generic, ALC897 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HD-Audio Generic, ALC897 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers```

Is there a way to get someone to look at this/where should I post to find an expert?

What do you get for the following commands?

pactl info
pactl list sinks

You can also try playing with the following commands, switching between different sinks:

$ pact list clients

$ pactl set-[TAB TAB]
set-card-profile          set-port-latency-offset   set-sink-input-volume     set-sink-volume           set-source-output-volume
set-default-sink          set-sink-formats          set-sink-mute             set-source-mute           set-source-port
set-default-source        set-sink-input-mute       set-sink-port             set-source-output-mute    set-source-volume

Thanks for the help! Here are the results

pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 35
Is Local: yes
Client Index: 62
Tile Size: 65472
User Name: me
Host Name: fedora
Server Name: PulseAudio (on PipeWire 0.3.38)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_04_00.6.HiFi__hw_Generic__sink
Default Source: alsa_input.pci-0000_04_00.6.HiFi__hw_acp__source
Cookie: 5331:8d3c
pactl list sinks
Sink #44
	Name: alsa_output.pci-0000_04_00.6.HiFi__hw_Generic__sink
	Description: Family 17h (Models 10h-1fh) HD Audio Controller Speaker + Headphones
	Driver: PipeWire
	Sample Specification: s32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 4294967295
	Mute: no
	Volume: front-left: 61604 /  94% / -1.61 dB,   front-right: 61604 /  94% / -1.61 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_04_00.6.HiFi__hw_Generic__sink.monitor
	Latency: 0 usec, configured 0 usec
		object.path = "alsa:pcm:1:hw:Generic:playback"
		api.alsa.path = "hw:Generic"
		api.alsa.open.ucm = "true"
		api.alsa.pcm.card = "1"
		api.alsa.pcm.stream = "playback"
		audio.channels = "2"
		audio.position = "FL,FR"
		device.routes = "2"
		alsa.mixer_device = "_ucm0003.hw:Generic"
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC897 Analog"
		alsa.id = "ALC897 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfc5c0000 irq 91"
		alsa.driver_name = "snd_hda_intel"
		device.profile.name = "HiFi: hw:Generic: sink"
		device.profile.description = "Speaker + Headphones"
		card.profile.device = "0"
		device.id = "45"
		factory.name = "api.alsa.pcm.sink"
		priority.driver = "936"
		priority.session = "936"
		media.class = "Audio/Sink"
		node.nick = "HD-Audio Generic"
		node.name = "alsa_output.pci-0000_04_00.6.HiFi__hw_Generic__sink"
		device.description = "Family 17h (Models 10h-1fh) HD Audio Controller Speaker + Headphones"
		device.icon_name = "audio-card"
		device.bus = "pci"
		device.bus_path = "pci-0000:04:00.6"
		node.pause-on-idle = "false"
		factory.id = "18"
		client.id = "32"
		node.driver = "true"
		factory.mode = "merge"
		audio.adapt.follower = ""
		library.name = "audioconvert/libspa-audioconvert"
		object.id = "44"
		node.max-latency = "8192/48000"
		[Out] Speaker: Speaker (type: Speaker, priority: 100, availability unknown)
		[Out] Headphones: Headphones (type: Headphones, priority: 200, availability group: Headphone Mic, not available)
	Active Port: [Out] Speaker