No grub menu when I disable plymouth. F38

Hi,

I don’t like plymouth. Why Fedora tries to mimic inferior OS like MS’s is beyond my comprehension. I’ve researched the internet how to disable plymouth to see the details of what happens on boot. However every single solution resulted on no grub menu at boot, which is not acceptable.

Here’s my /etc/default/grub

GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT="saved"
GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-0140d69f-4781-4439-9339-94a101794e2e rhgb quiet systemd.show_status=1 loglevel=3"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG="true"
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=1024x768*32

So far I tried to add 2 kernel parameters:

To disable Plymouth on Fedora 38 using grub kernel parameters, you need to modify some boot parameters in the /etc/default/grub file. Specifically, you need to add rd.plymouth=0 and plymouth.enable=0

and these commands:

sudo plymouth-set-default-theme details -R
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

to no avail.

Details:
https://www.phind.com/search?cache=tdfot66cviptf38f71631mgu
https://www.phind.com/search?cache=hotnt3nvmik0xd1ks3c19019

This I have not tested, given the 2 tests already failed:
sudo systemctl mask plymouth-start.service

It’s a fresh F38 installation (6 weeks?).

Normally, removing rhgb and quiet from the GRUB_CMDLINE_LINUX line would be sufficient to disable plymouth. I would suggest to test this by hitting the ‘e’ key when the grub menu is displayed. Then edit the command line and hit ‘x’ to start booting.

You may need to first revert /etc/default/grub to what it was before you made any changes to it.

2 Likes

Removing quiet results in a flood of detailed, and likely unnecessary, debug information being printed during boot-up. This deluge of data can hide the prompt for entering the password for LUKS encryption. To avoid this and simply disable Plymouth, I recommend only removing rhgb. This won’t affect the GRUB menu. I have tested this on Fedora Kinoite 39.

Correct, but if someone don’t like the plymouth splash, then that is what you get.

Thanks, I read earlier this solution was for older versions of Fedora.

I have no plymouth on Debian, and the quiet kernel parameter. This is perfect.

Thank you very much. Will test that. Looks promising. Will let you know.

I dnf remove plymouth on my systems and leave the grub settings asis.
It works fine.

1 Like

Unfortunately. No luck with this one either. Thanks anyway. Looks like Fedora team wants us not to see details when booting, mimimic Windows (which I despise) doing so.

Best!

Might be it, it has always worked on Debian. Will let you know.

A little rant. I miss the time when linux contained programs doing one thing and doing it well. Nowadays it’s crippled with windows-alike bloatware. Linux 2.2 or 2.4 booted in the blink of an eye on a 386 20Mhz PC. Try that with Linux 4, 5 or 6! Impossible. It’s began to deteriorate right at linux 2.6. One might not agree and I respect that, but it’s my opinion. Exactly as windows where the only acceptable versions throughout its history were XP and 7.1!

Run this command and you will see the details on every boot.

sudo dnf remove $(rpm -qa | grep plymouth)
1 Like

Unfortunately, that was not enough. Still no grub menu. However that was part of the solution, so you have all ma gratitude for that.

The second part of the solution is, on F38, to get rid of that rhgb parameter in addition to get rid of plymouth.

Hardly acceptable that is so complicated. Found that enlightening reading from 20 years ago of users manifesting their frustration about rhgb and its similarity with MS Windows. Worths the reading. And no amelioration in 20 years, so it does is the Fedora policy to hide those details. Borrowed from Redhat I reckon.

https://users.fedoraproject.narkive.com/CAGb5KxX/what-is-rhgb-on-the-grub-kernel-line

One last thing, use the video kernel parameter if you don’t want your console text to be squeezed in the top left corner of the screen. For a 1920x1080, those grub settings are best:

GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-0140d69f-4781-4439-9339-94a101794e2e quiet systemd.show_status=1 loglevel=3" video=1920x1080
GRUB_GFXMODE=1920x1080
GRUB_GFXPAYLOAD_LINUX=1920x1080*32

Forget doing that and you grub menu might be intermittent :frowning:

I just checked my systems and I have removed quiet and rhgb.
You have me curious about what rhgb is doing beside supposedly turning off plymouth.

Sorry, I forgot to post the link. Here we go.

https://users.fedoraproject.narkive.com/CAGb5KxX/what-is-rhgb-on-the-grub-kernel-line