No boot graphics even after a complete reinstall

I don’t know what’s wrong with the update a few weeks ago but since then, when I was still on the Cinnamon Spin, my LUKS prompt have become text-based and the usual spinner with HP’s logo is now only three square dots in the middle of the screen. Even after completely wiping out everything on my drive and reinstalling Fedora (I switched to the main Workstation for F37) the issue still persists.

Is it because of Windows? I have been dual-booting Windows 10 and Fedora for more than two months now, but this issue happens only recently. I haven’t got a chance to install only Fedora on my drive, though. Also I’ve tried changing the default plymouth theme to bgrt and spinner but to no avail.

Anyway here are what I got on boot:

Any help is greatly appreciated!

Oh, and also ever since then I’ve also been getting some texts that say something about “broadcasting” and “shutdown” when I shut it down. It often flashes for just less than a second, I haven’t been able to take a photo of it.

Do you get anything if you hit escape or ctrl + alt + F3?

It needs to add at the last of kernel parameter quiet splash.
To do that, edit grub2.cfg file properly and run a command update-grub2.

During boot? I only got a blinking cursor on the top left.

Same thing with Fedora ARM64 on Pi4B… Boot, services start, then NOTHING, no image, NOTHING.

1 Like
[firman@harry ~]$ dmesg
[    0.000000] Linux version 6.0.9-300.fc37.x86_64 ( (gcc (GCC) 12.2.1 20220819 (Red Hat 12.2.1-2), GNU ld version 2.38-24.fc37) #1 SMP PREEMPT_DYNAMIC Wed Nov 16 17:36:22 UTC 2022
[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt5)/vmlinuz-6.0.9-300.fc37.x86_64 root=UUID=b81787e9-0fd2-4205-9d55-1af42c4a1655 ro rootflags=subvol=root rd.luks.uuid=luks-df717762-ee07-4bc0-ab68-ef19448a8634 rhgb quiet

Huh, so apparently it’s missing the “splash” parameter…?
Do you have recommendation on how to properly edit grub2.cfg file? I found multiple different ways to do it. I do have backups already but currently I don’t have that much time to reinstall the OS.

Not even the three dots like on my photo?

Grub-customizer is great tool to edit booting scripts but it cannot edit own menu so, you have to configure the file such as vim, graphical text editor and so on.

I tried adding the “splash” parameter after “quiet”, and it is still there after I reboot it, but i’m not getting the usual boot graphics. Just saw other post that said you don’t have to put “splash” parameter if plymouth is using splash. So, I guess the issue is in plymouth?

Talk about plymouth, when I tried changing the default theme I ran

sudo plymouth-set-default-theme bgrt
sudo dracut -f
sudo plymouth-set-default-theme spinner
sudo plymouth-set-default-theme spinner -R

Don’t know if that’ll help but that’s all I did with plymouth on this installation.

Setting plymouth themes doesn’t take effect until you rebuild the initrd file

dracut -f

The issue is more likely to be the video driver and GPU. It could be that the GPU isn’t ready at the time plymouth is checking its capability.

Is it something like this?
Something to do with a timing that I won’t be able to do much about? TBH, I’m not sure I understand enough to know where to start. For now I’m changing my plymouth theme to “details”, the output lines one, since the background is darker.

If graphics aren’t working and you want an indication of it booting you can do,
sudo grubby --remove-args="rhgb quiet" --update-kernel=ALL

to put it back
sudo grubby --args="rhgb quiet" --update-kernel=ALL

Perhaps. It is a quite old error report, though

I don’t understand this either. If it is timing. then it could be that plymouth would display properly during poweroff as by then the GPU has been fully initialized.

Maybe a bugzilla report against plymouth could help.

Trying to the configuration sequence on the serial console, I created a completely new image on the SD card. Rebooted. Absolutely no video image on the HDMI monitor, but on the serial console I at least got some type of status as the Pi booted.

But… I still get no configuration screen or such… just a demand for login. And since this is a Pi4B ARM64 image, not a lot of options to tweak it.

This all I get…

[ OK ] Started sshd.service - OpenSSH server daemon.
[ OK ] Finished NetworkManager-wa…[0m - Network Manager Wait Online.
[ OK ] Reached target - Network is Online.
[ OK ] Reached target remote-fs-p…eparation for Remote File Systems.
[ OK ] Reached target - Remote File Systems.
Starting rpc-statd-notify.…- Notify NFS peers of a restart…
Starting systemd-user-sess…vice - Permit User Sessions…
Starting virtqemud.service…0m - Virtualization qemu daemon…
[ OK ] Started rpc-statd-notify.s…m - Notify NFS peers of a restart.
[ OK ] Finished systemd-user-sess…ervice - Permit User Sessions.
Starting gdm.service - GNOME Display Manager…
Starting plymouth-quit-wai… until boot process finishes up…
[ OK ] Started gdm.service - GNOME Display Manager.

Fedora Linux 37 (Workstation Edition)
Kernel 6.0.7-301.fc37.aarch64 on an aarch64 (ttyS1)

I see examples of doing configuration of Fedora via serial console, but they are NOT version 37, but version 33, 35, etc.

You guys (Fedora Team) are NOT making this EASY.

This is off topic. Please keep posts directed to the topic and relevant to the issue.

So, I tried it yesterday but I wasn’t sure what to look specifically for my issue.

Yeah I think I’m gonna do that.

Oh, they’re just replying to me asking for recommendation on changing the boot parameter.

Anyway, I really appreciate all the replies! Hope reporting it on the bugzilla will solve this issue.