No boot after changing default session from Wayland to Xorg


On my computer I have Fedora 36 running. I tried to start with Xorg session, since Wayland sometimes has problems with different applications.

I tried first to change it in the log in screen, which did not work. It never booted past the log in screen.

According to the description (Configuring Xorg as the default GNOME session :: Fedora Docs) I edited the custom.conf file.

However after that I could start fedora and failed at the Grub menu.
I used my external drive to start a fedora test session and excess my internal drive. I changed the custom.conf file back.
But I can still not start past the Grub menu.
Is there anything I can do?

Thank you so much,

We really need more info. The failure to boot to gnome on xorg from the gear icon on the log in (password) screen is troubling. IME absolutely nothing else is needed to switch the DM from wayland to xorg.

You have said that you edited the custom.conf file, twice. Please post the content of that file now (without further editing) so we can see if it exactly matches the default or not.

If you can get to the grub menu then try selecting a different kernel and let us know if that helps.

If it still fails then from the grub menu press an ‘e’ (edit) while the menu is visible and post the content that will then be displayed.

It may become necessary to boot into the live media and chroot into the installed system to do repairs but only one thing at a time.

Hi Jeff,

Thank you for the reply and help. Before you wrote I tried to find the problem on my own. I assume while trying to fix the issue on my own I messed up my system completely :sweat_smile:

At the end I decided to re install Fedora yesterday, after saving the important data. Now it is working properly, also the gnome on xorg from the gear icon.

I am not sure why it did not work before (switching with gear icon), my only assumption is that it happened while installing the nvidia driver last time.

Nevertheless, thank you