NFS mount RDMA/RPC error

Hi all,

To give a background to where I’m struggling

The kernel version used for server/client setup is below.

  • Server: 5.16.13-200.fc35.armv7hl
  • Clients: 5.16.13-200.fc35.x86_64 (Silverblue/i3 Spin)
    All systems were updated on Mar 15.
  1. Server: Config/firewall is done and the share (/etc/exports) exported to the clients. But I need your help on how to address this message. Do I need to correct values set in the [nfsd] section of the /etc/nfs.conf configuration file?

rpc.nfsd[927]: rpc.nfsd: Unable to request RDMA service

$ sudo systemctl status nfs-server.service
[sudo] password for xx:
● nfs-server.service - NFS server and services
Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; enabled; vendo>
Drop-In: /run/systemd/generator/nfs-server.service.d
Active: active (exited) since Wed 2022-01-12 00:00:40 GMT; 2 months 0 days>
Main PID: 938 (code=exited, status=0/SUCCESS)
CPU: 185ms

Jan 12 00:00:40 offroad systemd[1]: Starting NFS server and services…
Jan 12 00:00:40 offroad rpc.nfsd[927]: rpc.nfsd: Unable to request RDMA service>
Jan 12 00:00:40 offroad systemd[1]: Finished NFS server and services.

  1. Clients
    $ sudo showmount --exports nfs-server
    clnt_create: RPC: Unknown host

I don’t have clue what this is. Looks like NFS mount errors.

The guide used is here. Thanks!

1 Like

Are you able to connect via IP instead of hostname? It could be that your DNS is not resolving that host.

The result was when I put IP in the exports file.
The file I created looks like this;
/test/nfs_share IP address/24(rw,sync,no_all_squash,root_squash) # server
/test/nfs_share IP address((rw,sync,no_all_squash,root_squash)) # client 1
/test/nfs_share IP address(rw,sync,no_all_squash,root_squash) # client 2

An extra step I checked with the router was DHCP which was enabled.

Still the same. I’m not sure if I made a stupid mistake in the file/missed any steps with DHCP.

  1. Configure a static IP address in rc.conf: not done - is it necessary?
  2. Configure dhcp server in router: DHCPv4 Server enabled in my router
  3. Static DHCPv4 configured for server and clients
  4. Disable nps v4: is it necessary as suggested here?


If you’re using DHCP reservations, then you should be good. NFSv4 should work between a Fedora server and client. There have been a number of people reporting that NFSv4 has not been working between Fedora and Synology/QNAP stuff recently.

Regarding showmount -e failing, it looks like rpcbind might not be running? Can you verify that rpcbind is running on both ends (systemctl status rpcbind)? If not, you can enable it with systemctl enable --now rpcbind and then try showmount -e again.


rpcbind has been enabled as advised and it shows the following result with the correct IP address of NFS server.

$ showmount -e
Export list for offroad:
/test/nfs_share server IP address/24

But, RPC unknown host message persists. Is it normal?

$ sudo showmount --exports nfs-server
clnt_create: RPC: Unknown host

$ sudo mount | grep -i nfs
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)

1 Like

Just to get some obvious questions out of the way - is the client within that /24 submask? And is the nfs/rpcbind service enabled in firewalld (or nftables if not using firewalld) on both ends?

If so, I would run tcpdump on the server side as the client is trying to connect to see where it’s breaking down or if the client is even talking to it at all.

Why are there 2 lines for the clients in the server /etc/exports file? Is this necessary?

All in check. Still, the same message persists in the server and client.

I just want to define access for multiple NFS Clients in Export File, not an entire subnet. So I removed /24 subnet IP (I mixed up DHCP reserved IP with /24, which is my mistake). I use a single host.

I’ll put on hold running tcpdump until I complete exports file and fstab configuration.


The correction was made to the exports file as advised, thanks.

Result: the client spits out RPC unknown host message.


  1. How to define Access for multiple NFS Clients in Export File: Numerous articles suggest it is done in server exports file
  2. How to enable NFS over RDMA?

rdma.service does not exist.
$ systemctl enable rdma
rdma.conf file is empty

sudo vim /etc/rdma/rdma.conf file
2 files to edit

  1. What else do I need to do other than the /etc/fstab config file in client? Thanks!

Below is what I have done so far.

  1. Server: Server appears okay
    showmount -e
    Export list for offroad:
    /test/nfs_share /24

except for the Unable to request RDMA service

  1. Clients
    What works
    sudo mount | grep -i nfs
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)

I ran the following in the client and the result looks okay.

/usr/bin/rpcinfo -u <ip address or servername> mountd

program 100005 version 1 ready and waiting
program 100005 version 2 ready and waiting
program 100005 version 3 ready and waiting

What doesn’t

showmount --exports nfs-server
clnt_create: RPC: Unknown host

1 Like

Used Cockpit NFS mounts to populate path on server after sending /exports file to client (as followed through to the RedHat guide). It works! :slight_smile:

Ignore the previous RDMA/RPC errors.

How to find logs and troubleshoot storage issues in Cockpit

  1. Go to Logs or SELinux to check logs
  2. Check “solution details”
  3. Apply solutions when necessary
  4. View & run automation script if necessary

1 Like