New hunspell dictionaries I install do not appear in apps


Spell checker is not working for any hunspell dictionary I install.

I had the exact same setup with Fedora 33 and everything was working fine. I made a fresh install (not upgrade) of Fedora 34 and I can’t get any spell checking to work apart from the stock dictionaries e.g. en_US, en_GB, en_AU, etc.

I believe there is a problem with hunspell and some apps because my new dictionaries appear in Gnome Evolution when I use dnf install aspell-bg for example. I am mainly trying to get Poedit and LibreOffice to work but new dictionaries just do not appear in the menu. Hunspell works properly from the terminal by the way, so I think the issue is not missing packages.

I have been trying to find a solution for the last 3 days and I have installed every possible package that is even remotely connected but nothing helps. I have all relevant packages installed (enchant, hunspell, aspell, gtkspell, ICU, etc.) and I couldn’t find this reported as a bug anywhere so I decided to ask here.

I am a newbie, I am sorry if I am missing something. There are some screenshots at the bottom.

Thanks to everyone.


Can you please confirm where you’re installing Poedit and Libreoffice from? Are they from the repos, or are they Flatpaks from FlatHub?

I checked it with my F34 Mate and i got also the orange banner on the top. Installing the language in control panel/settings > Languages to that what I wanted to translate in Poedit. In my case it was German.

My installation of poedit was made with dnf.

1 Like

I tried both. However, I can now confirm that Poedit is working correctly once I installed it from the Fedora repo. Don’t know why, maybe I was missing some package before that. The flatpak version is still not working. Only LibreOffice is not picking up the new dictionaries. I tried reinstalling it again from both the repo and flathub but no success.

By the way, I checked now and the flatpak version of evolution is also not detecting the new dictionaries and it is not picking up any user themes/icons I am using.

I think Flatpak sandboxing may have something to do with it—they don’t use system libraries, and I’m not sure how aspell/hunspell etc are to be installed via Flatpaks. I expect they should be part of some runtime perhaps.

I see that libreoffice has lots of langpacks. Have you tried installing them?

sudo dnf list libreoffice-langpack*

I also see that libreoffice has it’s own dictionary installer:

Tools > Languages > More dictionaries online?

I think the langpacks are for the user interface. Also, when I check in Options → Language Settings → Writing Aids, Hunspell SpellChecker is available and turned on. As for the LibreOffice dictionaries - they don’t have Bulgarian. But… I downloaded the Bulgarian dict extension for Apache OpenOffice and installed it (by double-clicking) and the spellcheck is now working.

This is a good workaround I guess but if hunspell dicts could appear in LibreOffice that would be great. Hopefully this will be fixed soon. Thank you for taking the time to look into this.

If Libreoffice does provide spell checking for Bulgarian, but they aren’t in Fedora, please add a bug here on the Fedora bugzilla.

Libreoffice: open Bug List

On the otherhand, if Libreoffice does not include dictionaries for Bulgarian, it’ll be best to file a bug directly with the Libreoffice project. (Fedora packages Libreoffice but it does not develop it—like most of the software in Fedora).

1 Like