NetworkManager "Remembering" Removed Devices

Hello Everyone,

I’m having a strange behavior with network manager. I’ve removed the device using the nmcli command yet it keeps on coming back with I restart NetworkManager with the systemctl command. Not sure what to do. Or how to troubleshoot this behavior. I discovered this while I was attempting to override my /etc/resolver.conf file (which isn’t working also) via the NetworkManager.

I have tried the various UI components such as Advanced Network Manager and that still doesn’t work. Restarting NM or rebooting simply causes the device to return.

Any help would be appreciated, especially good resources of documentation regarding NetworkManager and Fedora. Lot’s of search results return Ubuntu Network Manager related issues and the solutions seem to point to directories that don’t exist on my current system.

So far…


nmcli connection show
sudo systemctl restart NetworkManager.service 

Please, post the exact commands you enter and the output you get including your steps to reproduce the problem.


I found the cause, not sure where it remembers the configuration. But if you attach a bluetooth device that supports DUN. It will automatically add it back into the list of available networks. You have to go to the bluetooth devices and remove the device from there.

  1. Remove the device from here
  2. So that it doesn’t come back when removing it Advanced Network Connections app.
1 Like

@vgaetera I’ll make a new post. Because this problem arouse when I was trying to figure out how to override my resolver.conf file through gnome and network manager.