Bluetooth not finding removed devices

Dear fedora users

I’m facing a problem for several days now and I just can’t figure out the problem, I recently switched to fedora but I’m having more problems with it than it should, one of them is bluetooth.
I have a bluetooth mouse and the first time to connect I had to uncomment the AutoEnable=true line and it worked perfectly. Then for some reason I connected the mouse to another computer and removed it from this one. Now it doesn’t show up on the devices list.
For my own debugging purposes I tried to connect my phone and it worked, removed it and now that device also disappeared, although I can still connect from my phone to the fedora computer.

I tried almost everything, from restarting bluetooth and the computer to using the command line (bluetoothctl) and I even reinstalled bluez.

Can someone please help me?
Thanks

Welcome to Fedora @jonas-vh

There is a command-line utility named bluetoothctl

Please execute this in a terminal and see if you get some more information. With help you get the available commands.

have tried bluetoothctl, the missing devices do not show up.