Network Manager

I have NM issue here. I have PCIe adapter where two M.2 cards installed. One for LTE and one for WiFi and BT. It is regularly failing in boot such a connection is not crated. When I shut PC completly and wait a moment and then boot it creates connection. How do I restart NM? {/etc/init.d/network-manager restart} announce that service do not exist command what I was using previously.

sudo systemctl restart NetworkManager.service

nmcli radio all
nmcli radio all off
nmcli radio all on

nmcli connection show
nmcli connection down CON_NAME
nmcli connection up CON_NAME

I am not sure about this. Isn’t it {nmcli connnection down/up Telia} gives unknown connection even that it is show list in that particular name. Is the adapter reason for it?

You can use shell autocomplete for the connection name.

Nope {nmcli connnection down/up [TAB]} gives nothing? And autocomplete enabled. Phuu.

There’s a typo.

You can also use the short version:

nmcli con sh

How you explain that:
{nmcli con sh}
Telia 181fcccb-9f31-40e6-ac4e-b618ef4cf407 gsm cdc-wdm0
{nmcli con down Telia}
Error: ‘Telia’ is not an active connection.
Error: no active connection provided.

It could be a bug if the connection is marked active but NM says it is not.

Yes, you confirm what I though also. I was scared to announce. It will also explain HW procedure. I boot up, and shutdown and few seconds and boot again to have LTE connection to PC. I also noticed difference in updates that they boot differently. How I can contribute Bugzilla?

1 Like

Fedora Docs > How to file a bug

1 Like

@vgaetera do you think you could help me troubleshoot a minor issue with my bluetooth? It only works after my laptop goes to sleep. The other issue is that my laptop does not always wake up from sleep (just a black screen), so I try to avoid it when possible but this means it is a crapshoot when I want to enable my bluetooth.

I have a ThinkPad E585. Below is the lspci line for what I believe to be the controller. All good if you can’t help, just thought I’d throw it out there since I’ve just been avoiding bluetooth for a while.

04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter