Network issues in fedora 35

Hello,

I’m using fedora workstation 35 as a client and a NFS NAS for storing data.
The NFS share is mounted by a line in the /etc/fstab file, as below:

192.168.1.40:/volume1/shared /mnt/shared nfs4 nofail,noatime,nodiratime,defaults,rw 0 0

I can mount the drive with no issues, the issue happens when trying to open data from the nfs mount, sometimes it gets stuck and no data can be read or written

I’ve checked I have permissions on the NFS share.

[user@host ~]$ showmount -e 192.168.1.40
/volume1/shared 192.168.1.39

[user@host ~]$ ip ro
default via 192.168.1.1 dev eno1 proto static metric 100
192.168.1.0/24 via 192.168.1.1 dev eno1 proto static metric 50
192.168.1.0/24 dev eno1 proto kernel scope link src 192.168.1.39 metric 100
192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 linkdown

I think something is wrong in the network config, because the same line is on other client (no fedora) and I can access the data with no issues and no stucks.

Any idea about something else to check will be appreciated.

Have you taken this in consideration?

Releases/35/ChangeSet - Fedora Project Wiki

Firewalld changed to newer version.

Hello luciano, thanks for your answer.

I was unable to see anything related NFS shares.
Do you think NFS outbound connection needs a specific firewall rule?
The NFS is mounted successfully on startup, if the issue is coming from the firewall, I think It wont be mounted at all, but I’m still having the issue when browsing on the shared folder.

It seems something is wrong in my network settings but still not identified.

[user@host ~]$ ping 192.168.1.40
PING 192.168.1.40 (192.168.1.40) 56(84) bytes of data.
64 bytes from 192.168.1.40: icmp_seq=1 ttl=64 time=1.48 ms
From 192.168.1.1 icmp_seq=2 Redirect Host(New nexthop: 192.168.1.40)
64 bytes from 192.168.1.40: icmp_seq=2 ttl=64 time=0.897 ms
From 192.168.1.1 icmp_seq=3 Redirect Host(New nexthop: 192.168.1.40)

What does it means “Redirect Host(New nexthop:)” In the same network with the same mask, the connection should be direct, right?

When it suddently starts failing the connection status change from ESTABLISHED to SYN_SENT, even with the firewalld stopped.

[user@host]$ sudo netstat -putona | grep 192.168.1.40
tcp 0 1448 192.168.1.39:891 192.168.1.40:2049 ESTABLISHED - on (34.77/8/0)
[user@host]$ sudo netstat -putona | grep 192.168.1.40
tcp 0 1 192.168.1.39:891 192.168.1.40:2049 SYN_SENT - on (11.28/4/0)

You have to go deeper in the wiki. Everything is linked.

It looks like you work on layer3 alias routing. Bridging is on Layer2 (osi model).
Do you use the NFS Share on a router? Mybe the port you connect is just routed. You wold have to put it in to bridged mode to be in same Network without routing.

How are this devices connected? With a managed switch? Or a router? A home network etc.

Hello luciano and thanks for the hints.

The NAS device is in the same network but in different switches.

I solved the issue by applying again the network config via nmcli and deleting the route below:
192.168.1.0/24 dev eno1 proto kernel scope link src 192.168.1.39 metric 100

[user@host ~]$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 eno1
192.168.1.0 0.0.0.0 255.255.255.0 U 100 0 0 eno1

Maybe I set the duplicate route by mistake after applying static IP address via UI, I had some issues and then I disabled the network manager and I set it up by editing the /etc/sysconfig/network-scripts/ifcfg-eno1

Removing the kernel route, the ping now is direct and stable and the NFS share is working like a charm:

[user@host ~]$ ping 192.168.1.40
PING 192.168.1.40 (192.168.1.40) 56(84) bytes of data.
64 bytes from 192.168.1.40: icmp_seq=1 ttl=64 time=1.16 ms
64 bytes from 192.168.1.40: icmp_seq=2 ttl=64 time=0.694 ms
64 bytes from 192.168.1.40: icmp_seq=3 ttl=64 time=0.895 ms

Thanks again for your support.
Have a nice day!

1 Like

@nfsmounter I’m happy that you found the solution.

Would like to invite you to make the questions on ask.fedoraproject.org next time.
It is more problem orientated (fedora linux).

While here it is more project orientated (fedora community in general)

:fedora: