Need help with samba when accessing smb version 1 devices

I have been using an old NAS device for several years and was always able to access from Linux until Fedora release 37 by using the following mount command:
sudo mount -t cifs -o “user=spooch,pass=secret,uid=1000,gid=1000” // /Xdrive/all_files

Now when I run the command, I get:

“mount error (22): Invalid argument. Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)”

Well, dmesg gives me:
CIFS: Attempting to mount \\all_files
cifs smb3_do-mount: 1 callback suppressed
CIFS: VFS: cifs.mount failed with returncode = -22

I understand the problem is that smb version 1.0 is old and has security problems but since I only access in house I am certain that there is no risk for me.

When I add vers=1.0 to the mount, the error message gives me some hope saying “Use of less secure dialect vers=1.0 is not recommended unless required for access to very old servers”

That is exactly what I want to do but I can not seem to be able to change the “default” to allow me to use the version 1.0 as I was able in the past.

Is there any solution other than purchasing new equipment?

try “vers=1.0,nodfs” as option to the mount command.

1 Like

Looks good! I tried it with one of the files and will put it in a script along with the others. But, from what I can see, it worked!

Thank you… I’ve been struggling with this for several weeks.

May I ask where you found the nodfs parameter?

Samba - ArchWiki