F34 Can't mount or access SMB-Share

Hi guys,

I run a couple of clients with Fedora and I’m “a bit” late with the upgrade from 32 to 34. Unfortunately I’m unable to access or mount samba shares anymore, while it is still working fine with the not upgraded clients still running on Fedora 32 (mounting and access via smbclient works). It is usually done with autofs, but also does not work if I try to mount it manually nor if i try to access the share with smbclient (username, hostnames etc. replaced):

[root@fedora34 ~]$ sudo mount -t cifs -o username=myusername //domain.inet/path/to/Share /media/screenshots/
Password for myusername@//domain.inet/path/to/share
mount error(4): Interrupted system call
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
[root@fedora34 ~]$ smbclient //domain.inet/path/to/Share -U myusername -W DOMAIN
Enter DOMAIN\myusername's password:
do_connect: Connection to smbserver-hostname failed (Error NT_STATUS_NOT_FOUND)
[root@fedora34 ~]$ rpm -q cifs-utils

I found two bugs which could be related to my problem, so I updated to cifs-utils 6.13 from testing (see above), but the error-messages where the same with stable 6.11.3

Because of the dmesg output Default has changed to a more secure dialect (I don’t know a which point exactly I got the message) I also tried to add vers=1.0 or vers=2.1 or vers=3.0 before username at the mount-command but without luck.

[20262.344385] CIFS: VFS: cifs_mount failed w/return code = -4
[20367.587410] CIFS: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=1.0 on mount.
[20367.587417] CIFS: Attempting to mount \\domain.inet\path
[20371.343988] CIFS: VFS: cifs_mount failed w/return code = -4

First I also had problems with the name-resolution via the internal DNS (also worked fine on F32). I thought I “fixed” this by replacing the /etc/resolv.conf symlink by a static one, but there seems to be still a problem because netcat can’t resolve the hostname (enp1s0 is my interface):

[root@fedora34 ~]$ host smbserver-hostname
smbserver-hostname.domain.inet has address 10.xx.xx.xxx
[root@fedora34 ~]$ nc -vz smbserver-hostname 445
Ncat: Version 7.80 ( https://nmap.org/ncat )
Ncat: Could not resolve hostname "smbserver-hostname": Name or service not known. QUITTING.
[root@fedora34 ~]$ nc -vz 10.xx.xx.xxx 445
Ncat: Version 7.80 ( https://nmap.org/ncat )
Ncat: Connected to 10.xx.xx.xxx:445.
Ncat: 0 bytes sent, 0 bytes received in 0.01 seconds.

So maybe it is (still) all related to the DNS-resolution? How do i configure a internal DNS-server “the Fedora 34-way”?

[root@fedora34 ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
search power.inet
nameserver 10.xx.xx.xx
nameserver 10.xx.xx.x
[root@fedora34 ~]$ resolvectl
         Protocols: LLMNR=resolve -mDNS -DNSOverTLS DNSSEC=no/unsupported
  resolv.conf mode: foreign
Current DNS Server: 10.xx.xx.x
       DNS Servers: 10.xx.xx.xx 10.xx.xx.x

Link 2 (enp1s0)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 10.xx.xx.x
       DNS Servers: 10.xx.xx.xx 10.xx.xx.x

At this point I don’t know how I should proceed and asking for your help :slight_smile:


Scanning the Changes between F32 - F 34 should be the first thing you have to looking for.
I copied you a link to the change to systemd-resolved. Probably there you have to look for your problem.
Releases/33/ChangeSet - Fedora Project Wiki
Changes/systemd-resolved - Fedora Project Wiki
Releases/34/ChangeSet - Fedora Project Wiki

1 Like

This may also be related to the differences between samba v 1 and the newer v 2+. I have heard of updates breaking access to v 1 servers.