Need help trying to suggest edits to Fedora Docs

Please forgive me if this is already covered somewhere.

I need help for two issues at the moment:

  1. I got a mention in gitlab, but I don’t know how to add further comments over there
    To highlight he requirement of using FAS SSO for the first time. (!13) · Merge requests · fedora / Fedora Docs / Community and Tools Documentation / Documentation Contributors Guide · GitLab

  2. I got 404 when click “Open in WEB IDE” when trying to edit
    Getting Started :: Fedora Docs

Fedora Workstation Edition

This variant is installed by using a Live CD

Software download at https://getfedora.org/de/workstation/

I intended to suggest removing the ‘/de’ from the download link.

No worries! If you have issues with any of these tools feel always free to open a ticket! Even if it is covered somewhere: if you cannot find it, this itself is an important information :wink:

You have to login with your account into gitlab, and then you should see at the bottom of the page you mentioned a text box to write comments, and a button below to post the comments. The bottom should look like that: modules/ROOT/assets/images/D-CommentsInMR.png · main · fedora / Fedora Docs / Community and Tools Documentation / Documentation Contributors Guide · GitLab

If your gitlab looks different, you could post a screenshot.

This is how my “To-do” list looks like:

This is how it looks after clicking on the To-do item:

Thank you very much for looking into this.

Interesting. It says at the bottom that it is locked, but at the right side it shows “Lock merge request” = “Unlocked”. I just logged in and it shows me that it is not locked. Theoretically, it should work. @darknao do you have an idea what causes this problem?

Concerning your other question:

Based upon your screenshot, it looks like it wants to open the fork in your account but that you have not yet created a fork. To further investigate this, it would be necessary to let us know the exact way that ended up at this point. Complementary, did you try to make this change based upon the steps of the 7-step guide? How does it work if you follow the 7-step guide? If it does not work with this guide: at which points does your outcome differ to the screenshots & information from the guide?

Yes, I am following the 7-steps guide Fedora Docs "HowTo" for casual contributions :: Fedora Docs

  1. In the same browser, I have my Gitlab logged in.
  2. Open the Docs link Getting Started :: Fedora Docs
  3. Click on the Edit button
  4. Click on “Open in WEB IDE”
    Got 404 error immediately.

So if you click on “Open in Web IDE” there does not appear the “fork” button as shown here? Sorry for asking again but I want to be sure about this. If so, we need to investigate this since I cannot tell you off my mind what causes this.

No - the “Fork” button did not appear.

Got the 404 error immediately after clicked “Open in WEB IDE”.

Update:

After testing with different browsers, clear cookies, reset FAS password. I suspect my issues are related to linking of Fedora Account with Gitlab account.

Now, I can see

And “Open in Web IDE” do not give me 404 - I got the “Fork” button as per the 7-steps guide.

Happy to hear that it works now! Indeed, I have myself not linked my two gitlab accounts to avoid such complications and keep my actions more transparent :wink:

But if I had to guess, I would assume it is more likely a browser or a related cookie issue rather than FAS-related.

So I consider this issue as solved for now. But may I ask which browser experienced these problems?

1 Like

Before my FAS password reset, both Chrome / Firefox on F37 have the same problem.

After FAS password reset, (Firefox have cookies cleared in between, Chrome never cleared cookies), both works.

How to unlink my FAS account with my Gitlab account?

I never did this myself. But maybe this helps you:

1 Like

Just to ensure that you have all information when making your decision about unlinking or not:

At ask.fp, someone just added a warning to the page header:

:warning: We are currently experiencing some problems with the Fedora Account System. If you are having trouble logging in, please try again shortly. We’re working on it.

So maybe your issue is also related to that and not directly to the gitlab linking.

1 Like

I discover the Gitlabs IDE UI is not as shown in the 7-steps guide. And I got lost when trying to add a one sentence note to using Overview to run GUI apps.

1 Like

I am sorry that the instructions do not apply (anymore) at one point. Could you explain the difficulties you experienced in a little more detail? It will help us to fix it.

Thinking pragmatically, when it comes to one sentence in one document, the Web UI is probably kind of an overkill. Editing the page directly via the button in the top right corner is then less effortful and more efficient.

2 Likes

I totally agree that there are better way to doing it.

Just that for my knowledge level, I am barely able to follow the 7-steps guide.

I will try to document my issue in more detail when I can.

Thank you very much for responding.

You can opt out of the new UI (beta) in the settings as here.

2 Likes

Maybe you can provide some details about where exactly the 7-step guide does no longer correspond to the current GitLab, and what the differences are? Maybe with some screenshots if this does not cause inconvenience to you?

I have not much time to contribute these days, and the above information would make it much easier. I might find some minutes next week to adjust the guide.

Thanks for your hint! I always appreciate if people make us aware of such issues.

The question that rises is if that new interface gets mandatory at some time. If this is already default in gitlab (which seems to be the case if @sampsonf did not activate it intentionally), we need to adjust the guide anyway for users without much gitlab experience: we have to tell them how to opt out, or adjust the guide for the new default UI.

1 Like

This one - after my edit, the “Create Commit” should turn blue …

This is what I got from the new UI.

Then I got lost.

I did not change any settings in Gitlab - and I got the new UI automatically.

Basically, I create Gitlab account just to report issues to projects hosted in Gitlab, and now mainly trying to do trival edits to Fedora Docs.

Thank you for sharing.

Yes, after opt out of the Beta UI, I got the old UI that matches the 7-steps guide.

1 Like

Since the guide is for beginners, I guess it makes sense to adjust it for the gitlab default. I guess this is easier for beginners than adding several steps to opt out. Hopefully, the new UI allows us to keep it with 7 steps :wink:

Thank you very much for the information. I try to find some minutes next week to adjust the 7-steps guide.

2 Likes