Name resolution stopped working

On Fedora 30 Thirty Kernel: x86_64 Linux 5.1.6-300.fc30.x86_64 name resolution for internet stopped working. No access to internet.

resolvectl query               -- link: eno1
                       -- link: eno1
                       -- link: eno1
                           -- link: eno1
                       -- link: eno1
                        -- link: eno1
                      -- link: eno1
                      -- link: eno1
                       -- link: eno1

-- Information acquired via protocol DNS in 170.6ms.
-- Data is authenticated: yes

Querying by resolvectl is successful.
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=50 time=119 ms
64 bytes from icmp_seq=2 ttl=50 time=118 ms
64 bytes from icmp_seq=3 ttl=50 time=118 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 117.849/118.098/118.507/0.499 ms

pinging by ip-number is successful too.

ping unknown host or service

Pinging or browsing by name unsuccessful

ss -pan 'sport = 53'
Netid                   State                    Recv-Q                   Send-Q                                      Local Address:Port                                       Peer Address:Port                                                                                 
udp                     UNCONN                   0                        0                                                                     *                       users:(("dnsmasq",pid=1604,fd=5))                            
udp                     UNCONN                   0                        0                                                                     *                       users:(("systemd-resolve",pid=1401,fd=16))                   
tcp                     LISTEN                   0                        32                                                                    *                       users:(("dnsmasq",pid=1604,fd=6))                            
tcp                     LISTEN                   0                        128                                                                   *                       users:(("systemd-resolve",pid=1401,fd=17))    
From my router (pfSense):
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=50 time=107.010 ms
64 bytes from icmp_seq=1 ttl=50 time=106.676 ms
64 bytes from icmp_seq=2 ttl=50 time=106.813 ms
--- ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 106.676/106.833/107.010/0.137 ms

Firewall on Fedora 30 is disabled.

What is used on Fedora 30 for name resolution? systemd-resolve or dnsmasq?
How to clean Fedora 30 from old remains in name resolution and reset/repair name resolution?

1 Like

I don’t think that the status of your firewall is significant, for two reasons. First, because it has to let responses to DNS queries through to allow your computer to resolve machine names into IP addresses, and second because disabling it doesn’t make a difference. If you haven’t already, please turn it back on.

Second, I’d appreciate it if you can post the contents of /etc/resolf.conf here so that we can see what nameservers your machine is trying to use.

I have disabled firewall to exclude any side-effects from firewall.

/etc/resolv.conf is a symlink:
lrwxrwxrwx. 1 root root 28 7. Jun 19:16 resolv.conf -> /var/run/connman/resolv.conf

file /var/run/connman/resolv.conf doesn’t exist. folder /var/run/connman is empty.

I tried with different/various name servers and network connections LAN and WLAN.

Executing command “resolvect query” on the machine is successful. This proves name resolving can be done on the machine concerned, but commands like ping and browsers don’t get/see the resolvings for the names.

The problem is:
resolvectl can resolve names, but ping and browsers can’t.


Solved. I put nameserver into /etc/resolv.conf.

Nice, but it is strange since it should be handled by NetworkManager. Isn’t it?

Yes, it is strange. Entry “nameserver …” in resolv.conf disappears after reboot.

May be transition(s) to newer NetworkManager with systemd creates confusion. Also backward compatability.

It doesn’t matter. It is my old Fedora installation 29/30 upgraded since … which was damaged by freezings due to old firmware of Samsung SSD.