Mutter(?) requires quite some time to handle firefox windows

Does anyone experience the same? If you start firefox freshly from dash, the browser window comes up and is ready to be used, but Gnome’s top bar keeps on showing the spinning wheel next to firefox application for about 10 seconds (see screenshot):

Firefox is responsive during that time, you can even open further firefox windows.
But you cannot switch with Meta-~ between these windows.

Once the spinning wheel vanished, everything seems back to normal.

If you open firefox through Terminal, this is not happening, so I guess it must be related to the way firefox is started from the dash.

This is a common issue with several applications - notably also LibreOffice, related to StartupNotify. It sometimes causes an icon to appear in the task switcher only after perhaps 30 seconds after it has loaded. To work around the issue, copy the .desktop launcher to your ~/.local/share/applications directory, and set “StartupNotify=false”.

1 Like

Thanks, that workaround did its job. I noticed that this issue is also with Terminal.
Bad thing is that if I do a window switch with Meta-Tab, then it happens occasionally that Mutter “forgets” some windows completely – they are not appearing in the Meta-Tab switch popup anymore.

Are you aware of any bug report for this issue?
If not, for which Gnome software would I need to open a ticket?
Interestingly, I found an issue report filed 4 years ago under Passwords and Secrets (StartupNotify too slow (#3) · Issues · GNOME / Passwords and Secrets · GitLab).
I’m pretty sure that this behavior got introduced with F37.

Only these apps for which “StartupNotify=true” in the .desktop launcher may have the issue: the default is “false”. Typically, GTK3/GTK4 apps do not have the issue, so I am surprised to hear you have the issue with Terminal. I do not know of a bug report on this, but the problem, at least on Ubuntu, exists for as long as I use Gnome 3 on Ubuntu (and that is from the beginning). If it is to be filed, it is for Gnome Shell, obviously. It is the shell’s job to have the task switcher right. I am pretty certain that the issue has not been introduced with F37.

1 Like


[chris@fedora ~]$ grep Notify /usr/share/applications/org.gnome.Terminal.desktop 

Starting it from Gnome (either from Dash or from Activities by typing terminal) results in

Fun thing is that while the wheel is spinning (and, yes, it takes 20-30 seconds), I can logout, the Terminal windows closes, but the entry in the bar plus the spinning wheel stays for those 20-30 seconds.

(I’m pretty sure that I would have noticed this behavior on F36, as it is really annoying :wink: )

I am confused now, because your screenshot does not show Terminal. In your first post, you suggested the application immediately opens, yet in the top bar the spinning wheel keeps turning (and in the Alt+Tab switcher, the icon is not (yet) there. Not seeing Gnome Terminal means it is not properly launching.

Second, I suggested to set “StartupNotify=false”, however, you kept it on “true”.

Maybe you missed the screenshot in my previous post. It does show Terminal window and its spinning wheel.
I was following up to

Typically, GTK3/GTK4 apps do not have the issue, so I am surprised to hear you have the issue with Terminal.

which lead me to think that maybe they do have a different default StartupNotification setting (which is not the case; that’s why I posted the grep output).

At the moment, it looks like the best fix would mean to copy all launchers from /usr/share/applications to ~/.local/share/applications and setting StartupNotification to false for all.

Will install F36 and see if behavior is really there, too.

It’s the same on F36 with gnome-terminal.

Found the bug report:

The report is referring to a gtk3 issue:

From additional information section:

Happens only on Wayland session after 3.24.35 update. Downgrade to 3.24.34 fixed it

(3.24.35 has been introduced on F36 three weeks ago (; that was after me migrating to F37, thus I didn’t experience this behavior on F36)

1 Like

That sounds like it.

By the way — an easy way to help contribute to the project is to run with “updates testing” enabled, and then hopefully we can catch these issues while they’re still in the update system waiting for feedback.

My sincere apologies! I am so used to a dark terminal that I mistook your window for gedit :slightly_smiling_face:

Does the icon of Terminal appear in the Alt+Tab task switcher while you have this busy icon?

I cannot reproduced the issue on my Fedora 37 installation (fresh install).

That is what I do for LibreOffice only thus far.