Mullvad Browser Does Not Open External Links

Fedora Linux 37 Workstation Edition
Mullvad Browser

When I select a link in another application, (email or Bitwarden for example) Mullvad Browser opens my browser home page, not the link address page.
I have no other browsers installed.

Please help!

I am not familiar with Mullvad Browser, but my first guess is the desktop file is not correctly set up to receive URLs.

Can you run the following command in a terminal and reply with the full output:

grep '^Exec' -- $(locate -i '*mullvad*.desktop') /dev/null
1 Like

Btw, this may be intentional as Tor Browser (which Mullvad Browser is based on) does not recommend setting as a default browser.

[rosie@desktop ~]$ grep '^Exec' -- $(locate -i '*mullvad*.desktop') /dev/null
/home/rosie/.local/share/Trash/files/start-mullvad-browser.desktop:Exec=sh -c '"$(dirname "$*")"/Browser/start-mullvad-browser  --detach || ([ ! -x "$(dirname "$*")"/Browser/start-mullvad-browser ] && "$(dirname "$*")"/start-mullvad-browser --detach)' dummy %k
/home/rosie/.local/share/applications/start-mullvad-browser.desktop:Exec=sh -c '"/usr/lib64/mullvad-browser/Browser/start-mullvad-browser" --detach || ([ !  -x "/usr/lib64/mullvad-browser/Browser/start-mullvad-browser" ] && "$(dirname "$*")"/Browser/start-mullvad-browser --detach)' dummy %k
/usr/lib64/mullvad-browser/start-mullvad-browser.desktop:Exec=sh -c '"/usr/lib64/mullvad-browser/Browser/start-mullvad-browser" --detach || ([ !  -x "/usr/lib64/mullvad-browser/Browser/start-mullvad-browser" ] && "$(dirname "$*")"/Browser/start-mullvad-browser --detach)' dummy %k
/usr/lib64/mullvad-browser/Browser/start-mullvad-browser.desktop:Exec=sh -c '"$(dirname "$*")"/Browser/start-mullvad-browser  --detach || ([ ! -x "$(dirname "$*")"/Browser/start-mullvad-browser ] && "$(dirname "$*")"/start-mullvad-browser --detach)' dummy %k
[rosie@desktop ~]$ 

It looks like the app installed the desktop file for your user (or you copied it yourself). This file /home/rosie/.local/share/applications/start-mullvad-browser.desktop is the one that shows up in your GUI launcher and takes precedence over other files, so any changes should be made to this file.

As I guessed, it does not handle URLs. A normal browser’s Exec key would look like this (Firefox for example):

Exec=firefox %u

where the %u means a single URL.

Now, the problem is this Mullvad Browser’s Exec key is somewhat complicated, so I don’t think you can just add a %u or %U somewhere. It points to a program /usr/lib64/mullvad-browser/Browser/start-mullvad-browser that probably handles options and does other things like set up the browser before starting it.

Based on this, it’s clearly intentional that it doesn’t handle URLs from other apps.

If you want to try anyway, you would need to look at the start-mullvad-browser program (hopefully it’s a shell script) and figure out what it does, and whether you can pass a URL to it. Otherwise I suggest you contact Mullvad by opening an issue here or emailing them.

This works for me:

# Download
wget --content-disposition -P /tmp -c \{,/signature}

# Verify
gpg --auto-key-locate nodefault,wkd \
gpg --verify /tmp/mullvad-browser-*.asc

# Extract
tar -C ~/.local/share -J -x -f /tmp/mullvad-browser-*.tar.xz

# Configure launcher
cd ~/.local/share/mullvad-browser
./start-mullvad-browser.desktop --register-app
desktop-file-edit \
--set-key=Exec \
mullvad-browser/Browser/start-mullvad-browser --detach %U" \

# Configure MIME types
xdg-mime default start-mullvad-browser.desktop \
text/html x-scheme-handler/http x-scheme-handler/https \
x-scheme-handler/mailto x-scheme-handler/webcal

# Test

Thank you, I emailed Mullvad Support an am awaiting a reply.

Thank you so much for doing the work on laying out the install so nicely.
Mullvad Linux install was more a manual affair and was maybe where I could have messed up - if this worked for you am hoping it will for me too.
I wont be at this machine again for a week bit will let you know then.

1 Like

Works perfectly following your install instructions, thank you!

I suggest the following edit to enable wayland:

–set-value=“env MOZ_ENABLE_WAYLAND=1
mullvad-browser/Browser/start-mullvad-browser --detach %U”

And to enable touch screen scrolling you need to change:

from 0 to 2