Most websites wont open


Im kinda new to linux so i hope the explaination of my problem wont be too horrible.

Everytime i try to open a website, it only shows me the error message: “Hmm. We’re having trouble finding that site” Only certain websites like g-mail or facebook work. I tried running an
internet speedtest in google and yes, it says im connected to the internet.

When i try pinging in the terminal its unreachable(i read in another forum i should try that).

As i said its my 2nd day of using linux, and i have no clue how to resolve this Issue.

If anyone knows something about how to solve this problem a qick explaination would be well appreciated.

Welcome to the community, Lenny!

Just to cover the bases, you’re sure you’re connected to the internet? You wrote you can connect to some websites, so I’ll guess you are; however, have you tried connecting to a different network to see if the issue persists?

Hi Lenny,

That’s strange. The fact that you cannot ping to means that you do not have connection to the V4 version of the internet. So either the sites working get their page from the browser cache, which means that it should have worked before, or you’re only connected to the V6 version of the internet.

Can you please open a terminal, and post the output of

ip addr show | grep inet
ip route show


I appreciate the help. I hope i did everything right,but heres the outcome of the commands you suggested me to run.

Screenshot from 2023-06-19 17-49-52

the commands grep inet and ip route show had no outcome. (i ran ip route show seperatley aswell)


I appreciate the help.

Yes, i am sure that im connected to the Internet,since i can vistit youtube and watch videos there for example. However i have not tried another network since i am connected with an ethernet cable. Ill make sure to try this tho.

Those images for ip a do not show a IPv4 address enabled. In fact they show an additional interface (enp42s0) that probably should not be there.

Simply go to the gnome → settings panel and under the network config first delete (forget) the extra interface config for enp42s0. Then verify that IPv4 is enabled (and maybe disable IPv6) for enp4s0. That should solve the issue.

But enp42s0 is connected, enp4s0 has no carrier. Sorry about “ip route”, but this is equivalent to “ip -4 route” and you appear not to have ipv4. “ip -6 route” shows the ipv6 routes and should be fine. Be sure that in for the working connection IPv4 is set to automatic(dhcp) and IPv6 to automatic, which is actually the default.
IPv6 is the modern way to connect to the internet and it works, but not all sites already support it.
You can type in a terminal “sudo journalctl -b -u NetworkManager -g dhcp4” to see whether there are any errors concerning DHCP4.
If you have a Windows PC, you can open a command prompt and type “ipconfig /all” and see whether it gets its IPv4 addresses from DHCP.

Sorry that I forgot the simple thing: in a terminal, just “nmcli” gives an overview of the network connections.


thanks for you’re help again.

I tried running both of those commands, and made sure i had those two options set to automatic like you told me. I also ran the command in windows, (i dualboot) but it said everythings fine.

also heres the result of ip -6 route:

Thank u for you’re response but im confused about how to access the GNOME settings panel. In settings theres no GNOME option and not in search either. It only showed an app named Tweaks by “The GNOME Project”. I did end up installing it since i thought maybe thats what you meant but it didnt even have a Networks tab.

As i said im still new to linux and i have no clue how to access that kinda stuff. I ran a command i found : gnome-control-center - Configure GNOME settings.

thats what showed up:

There are some IPv6-only ISPs, and they require DNS64 to reach IPv4-only sites over NAT64.

Can you show the network configuration on your Windows system? We see that the network configuration on you Linux system is IPv6 only, but is that also the case for your WIndows system?


i hope this is what you meant with Network Configuration.

Thank you for you’re help

That shows both IPv4 and IPv6 config with addresses for both. It also shows a gateway configured for both ip-4 and ip-6.

There have been cases where the ‘spurious’ interface config such as you have with ‘enp42s0’ and ‘enp4s0’ was the cause of similar network issues and IIRC removing the extra interface within the gnome settings panel solved it.
The fact that it configures that way when one has only one physical interface seems to indicate the strange config may be the cause of your problems.


Sorry for asking cause i cant seem to figure it out,how exactly can i access the gnome settings panel? And how would i be able to remove stuff in there?

Just hit your “super” (Windows) key and type “settings;” the gnome control panel should be the entry titled “Settings.”

ohhhh thank you that makes a lot of sense. I was there a lot already i just thought the gnome control panel is something different.

I dont know if u mean the interface on the picture below but if its the right one what exactly do i have to do next?

That seems the correct panel.

Simply disable the enp42s0 connection then enable the enp4s0 by clicking on the + button beside it and enabling a profile for that interface. The one can be deleted by first turning it off with the button having the blue beside it, then clicking on the gear icon and selecting the Remove Connection Profile button that should appear.

Sadly, it still doesnt work.

When using enp4s0, theres no connection at all,even tho its says “connected - 100Mb/s”

There is an icon that looks like a gear wheel. Try click on that.