Mobile Broadband Issues 2

,

I don’t mean to hijack the thread, I hope you don’t mind me stepping in since I have the same problem on my hands.

I do believe the issue arises from the changes that came with the upgrade from 34 to 35. There is quite some changes to the Mobile Networks section of the Settings panel now. There seems to be inadequate communication of some sort with the Network Manager - I’ve noticed that the OS keeps automatically creating a new “Standard” connection every time I plug in the USB modem and turn Mobile Connection on. At the same time connections that I’ve created with the Network Manager GUI don’t show up in the Mobile Connections section of the Settings panel, but they do show up in the drop-down menu in the upper right corner of the screen (I use the Gnome desktop).
I’ve confirmed that the problem is not in the USB modem or the SIM-card or the APN I’ve input - the device continues to work just fine on another machine, just like it did on my Fedora installation before the version upgrade.

On my machine nmcli connection up wifi returns Error: unknown connection 'wifi'. I do have WIFI turned on, working, and an active connection to a wireless modem.

Well your connection name may be different. If you run nmcli connection show it should provide the name of your wireless connection.

A USB device is reconfigured each time it is connected/booted/disconnected and may even take a different device name. For example, with my 3D printer, if I unplug it then plug it back in, what was originally /dev/ttyUSB0 may become /dev/ttyUSB1 and that WILL interfere with the original config and communications. USB devices are configured and removed by udev so to ensure 100% that it is always configured the same you need a rule in /etc/udev/rules.d/ to define how that device should always be configured.

Sorry the name is likely something like wlp3s0 or similar, wifi is the “type”.
There is also rfkill, if you run that and it reports your wlan is HW unblocked and SW blocked rfkill unblock wlan will unblock the SW side and you should be good to go. You may need to be sudo for those commands that change things.

wlan was unblocked under both SOFT and HARD. I ran sudo rfkill unblock wlan anyway for good measure, but nothing changed.

nmcli connection show lists saved connections. The saved Mobile Broadband connections are listed as gsm under TYPE, but under DEVICE for these connections there is just --, although the USB modem is plugged in and powered by the machine. The bridge and wifi connections do have listed devices.

When I try to manually activate the connection from Terminal I get this activation error:

IP configuration could not be reserved (no available address, timeout, etc.)

And this is from the journalctl records:

e: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
 starting connection 'new' (0dac0398-866e-4188-a970-7a011350be2b)
e: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
e: prepare -> config (reason 'none', sys-iface-state: 'managed')
e: config -> ip-config (reason 'none', sys-iface-state: 'managed')
e: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
 failed for connection 'new'

I think I see some confusion here. I know I was misled by my initial understanding.

Your issue at least is an issue with the broadband connection and not the wifi connection and most of the suggestions to date have been wifi related.

This means the issue is likely a driver missing.
Please post the output of dmesg | tail run immediately after plugging in the broadband modem then also inxi -Fxx as well as lsusb while the modem is plugged in. These bits of information may allow us to identify the exact chipset in the modem so we can verify the driver and get the device properly configured.

You also should tell the system to forget the earlier connections seen in the menu from the upper right of the screen so you are working with only one when done.

I agree your issue is similar to the OP, but it is different hardware and thus the fix is likely different.

Well your connection name may be different. If you run nmcli connection show it should provide the name of your wireless connection.

1 Like

The modem is ZTE MF667 (firmware version: BD_MF667V1.0.3B01). Here are the outputs from the commands:

dmesg | tail:

[12366.952793] scsi 2:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
[12366.954487] sd 2:0:0:0: [sdb] Media removed, stopped polling
[12366.954659] sd 2:0:0:0: Attached scsi generic sg1 type 0
[12366.970463] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[12367.032095] sd 2:0:0:0: ioctl_internal_command return code = 70000
[12367.032120] sd 2:0:0:0: Sense Key : Hardware Error [current] 
[12367.032122] sd 2:0:0:0: Add. Sense: No additional sense information
[12367.116376] sd 2:0:0:0: ioctl_internal_command return code = 70000
[12367.116387] sd 2:0:0:0: Sense Key : Hardware Error [current] 
[12367.116389] sd 2:0:0:0: Add. Sense: No additional sense information

inxi -Fxx:

System:    Host: lyubo-fedora Kernel: 5.15.5-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc 
           v: 2.37-10.fc35 Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 
           Distro: Fedora release 35 (Thirty Five) 
Machine:   Type: Laptop System: TECLAST product: F7 v: N/A serial: <superuser required> 
           Mobo: TECLAST model: F7 serial: <superuser required> UEFI: TECLAST 
           v: K3D4_A1 tPAD 3.02 date: 03/21/2018 
Battery:   ID-1: BAT0 charge: 50.0 Wh (100.0%) condition: 50.0/N/A Wh volts: 7.6 min: N/A 
           model: Intel SR 1 SR Real Battery serial: 123456789 status: Full 
CPU:       Info: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP arch: Goldmont 
           rev: 9 cache: L2: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8755 
           Speed: 801 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 801 2: 2054 3: 1508 
           4: 1128 
Graphics:  Device-1: Intel HD Graphics 500 driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5a85 
           Device-2: Alcor Micro USB 2.0 PC Camera type: USB driver: snd-usb-audio,uvcvideo 
           bus-ID: 1-8:7 chip-ID: 058f:3841 
           Display: wayland server: X.Org 1.21.1.3 compositor: gnome-shell driver: 
           loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel HD Graphics 500 (APL 2) v: 4.6 Mesa 21.2.5 
           direct render: Yes 
Audio:     Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
           driver: snd_hda_intel v: kernel bus-ID: 00:0e.0 chip-ID: 8086:5a98 
           Device-2: Alcor Micro USB 2.0 PC Camera type: USB driver: snd-usb-audio,uvcvideo 
           bus-ID: 1-8:7 chip-ID: 058f:3841 
           Sound Server-1: ALSA v: k5.15.5-200.fc35.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.40 running: yes 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus-ID: 01:00.0 
           chip-ID: 8086:3165 
           IF: wlp1s0 state: up mac: 34:41:5d:22:80:85 
           IF-ID-1: virbr0 state: down mac: 52:54:00:57:a3:53 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
           bus-ID: 1-7:6 chip-ID: 8087:0a2a 
           Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running 
           rfk-block: hardware: no software: yes address: see --recommends 
Drives:    Local Storage: total: 178.87 GiB used: 109.55 GiB (61.2%) 
           ID-1: /dev/mmcblk0 type: USB vendor: Samsung model: EC2QT size: 59.62 GiB 
           serial: 0x746753ce 
           ID-2: /dev/sda vendor: Teclast model: 128GB NS550-2242 size: 119.24 GiB 
           speed: 6.0 Gb/s serial: AA000000000000000931 
Partition: ID-1: / size: 117.66 GiB used: 52.59 GiB (44.7%) fs: btrfs dev: /dev/sda3 
           ID-2: /boot size: 975.9 MiB used: 241.3 MiB (24.7%) fs: ext4 dev: /dev/sda2 
           ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat dev: /dev/sda1 
           ID-4: /home size: 117.66 GiB used: 52.59 GiB (44.7%) fs: btrfs dev: /dev/sda3 
Swap:      ID-1: swap-1 type: zram size: 5.62 GiB used: 29 MiB (0.5%) priority: 100 
           dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 608 Uptime: 3h 28m Memory: 5.62 GiB used: 3.06 GiB (54.4%) 
           Init: systemd v: 249 runlevel: 5 target: graphical.target Compilers: gcc: 11.2.1 
           Packages: note: see --pkg flatpak: 45 Shell: Bash v: 5.1.8 
           running-in: gnome-terminal inxi: 3.3.06

lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 058f:3841 Alcor Micro Corp. USB 2.0 PC Camera
Bus 001 Device 006: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 012: ID 25a7:fa61 Areson Technology Corp Elecom Co., Ltd MR-K013 Multicard Reader
Bus 001 Device 016: ID 19d2:0031 ZTE WCDMA Technologies MSM MF110/MF627/MF636
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

shows the device in lsusb. It also is shown with the first line of the output from dmesg.

This means the system sees it, but is not properly configuring it.

I found this link with a search for the line I quoted above and it seem relevant to your issue. I realize that is an old bug discussion but it likely will still apply in that it seems the fix was to create a udev rule so the system properly recognized and configured it. There were other links as well but I did not review all.

If that modem worked with F34 and the upgrade to F35 broke it then it certainly should be reported as a bug since something caused the previously functional device to be no longer configured properly. In fact I would venture that it is almost mandatory that a new bug be filed, even if you get it working with a udev rule. Only with a bug report will the developers be informed of the regression caused here.
https://bugzilla.redhat.com/post_bug.cgi

No luck yet. Using gedit I added the device to 40-usb_modeswitch.rules, but that didn’t change things. I still get the same behavior and the same output I posted above when I try to manually start the mobile broadband connection.

From your command inxi -Fxx your device name not wifi, but wlp1s0. For the exact name you could check with what @jakfrost suggested above. You’ll never be able to run nmcli connection up wifi if your device name are not wifi for activate Wifi connection.

nmcli connection up doesn’t work neither with the TYPE nor the DEVICE arguments, it works with the NAME argument and that’s the way I use it to try and manually activate said connection - nmcli connection up [name-of-connection]. In this syntax the command turns on and off my WIFI connection just as it should, but, as I said, it returns the activation errors I posted above when I try to turn on my broadband connection.

Ah, I see. Maybe what I quoted above are the problem.

Maybe you could follow instruction from official Intel page here to install the driver. On that page there a driver Intel® Dual Band Wireless-AC 3165.

Update:

Extract it then find file with ucode extension. Compress ucode files with xz -z *.ucode then copy it to /lib/firmware.

Careful. This topic is about his broadband modem. The wifi is working.

1 Like

Ah my bad. I though it’s about wifi since he reported about wifi.

Found exactly the same type modem MF110/MF627/MF636 here. From this link, you’ll get another link on how to configure it.

Related packages: wvdial, ppp, usb_modswitch .

No luck here as well.

My last idea. SInce the output of your lsusb already mention Bus 001 Device 016: ID 19d2:0031 ZTE WCDMA Technologies MSM MF110/MF627/MF636 from the article means the dongle already detected as modem by the system (the are commons two mode: storage and modem).

May be you could narrow it down on the setting of wvdial.

OK, so I tried a more comprehensive documentation for wvdial and I got to the following: After I installed the package I ran wvdialconf /etc/wvdial.conf to create and fill in the configuration file (as per instructions) and after scanning the ports for a modem it returned Sorry, no modem was detected! Is it in use by another program? Did you configure it properly with setserial? This with the Broadband Connections being turned on or off from the Settings panel and while the modem is plugged in, recognized, and powered by the system.

Is it possible maybe that there is a mounting issue at play?

Do you see the modem OK with the modem manager command mmcli ? I could on my system and get all the details about the cellular connection, which indicates that the modem is mounted OK.