Macbook Air 2019 install with T2 chip

Hello everyone,

I’ve just installed Fedora 37 on my macbook air 2019 model. Tbh I’m quite new at Linux, though I’ve managed to do a few things here and there.

After trying to update the system I’m getting this error:

Errors during downloading metadata for repository 'mbp-fedora':
  - Status code: 503 for (IP: 64:ff9b::22f1:7343)
Error: Failed to download metadata for repo 'mbp-fedora': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

I’ve followed this page:

and I’m currently running:

[muj@TheEagle ~]$ uname -r

Hope someone can help me.

I don’t know why you installed/enabled that repo, but to stop it from giving the errors you can first run dnf repolist to see the actual name of the repo as dnf recognizes it, then dnf config-manager --disable <repoid> will disable it (semi)permanently and stop those errors.

Alternatively if you only want to disable it for a single dnf session you can add the option --disablerepo <repoid> in the dnf command line.

Substitute the actual repoid seen from the 'dnf repolist` command in those 2 places.

Hi @computersavvy thank you for your reply,

I suppose that part of the problem is that I’m doing many things which I don’t fully understand. So I too don’t know why I installed or even how/when I installed that repo list.

I was wondering whether the correct thing to do would be to remove the repository. What I need to know is will I get new kernel updates like normal when I run: sudo dnf upgrade?

As I mentioned I was wondering before whether to remove the repository and had googled the how’s of doing it. I found something slightly different from what you mentioned.

dnf config-manager --set-disabled ***repository***

Also there is this:

rm /etc/yum.repos.d/***file_name***.repo

My output for yum repositories and repolist:

[muj@TheEagle ~]$ cd /etc/yum.repos.d/ ; ls
_copr_phracek-PyCharm.repo           mbp-fedora.repo
fedora-cisco-openh264.repo           rpmfusion-free.repo
fedora-modular.repo                  rpmfusion-free-updates.repo
fedora.repo                          rpmfusion-free-updates-testing.repo
fedora-updates-modular.repo          rpmfusion-nonfree-nvidia-driver.repo
fedora-updates.repo                  rpmfusion-nonfree.repo
fedora-updates-testing-modular.repo  rpmfusion-nonfree-steam.repo
fedora-updates-testing.repo          rpmfusion-nonfree-updates.repo
google-chrome.repo                   rpmfusion-nonfree-updates-testing.repo
[muj@TheEagle yum.repos.d]$ dnf repolist
repo id                              repo name
fedora                               Fedora 37 - x86_64
fedora-cisco-openh264                Fedora 37 openh264 (From Cisco) - x86_64
fedora-modular                       Fedora Modular 37 - x86_64
google-chrome                        google-chrome
mbp-fedora                           mbp-fedora
phracek-PyCharm                      Copr repo for PyCharm owned by phracek
rpmfusion-free                       RPM Fusion for Fedora 37 - Free
rpmfusion-free-updates               RPM Fusion for Fedora 37 - Free - Updates
rpmfusion-nonfree                    RPM Fusion for Fedora 37 - Nonfree
rpmfusion-nonfree-nvidia-driver      RPM Fusion for Fedora 37 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam              RPM Fusion for Fedora 37 - Nonfree - Steam
rpmfusion-nonfree-updates            RPM Fusion for Fedora 37 - Nonfree - Updates
updates                              Fedora 37 - x86_64 - Updates
updates-modular                      Fedora Modular 37 - x86_64 - Updates
[muj@TheEagle yum.repos.d]$

To clarify my questions are:

  1. is using dnf config-manager the same as rm /etc/yum.repos.d/***file_name***.repo and should I do both and should I do the one I found or with the syntax you mentioned?

  2. So I take it from your reaction that I don’t need that repository? Will I still get the kernel updates I need for this mbp kernel I’m using?

Thank you in advance for your time and help

lol Just read again and have answered one of my own questions. The config-manager is for disabling and the rm command is to remove the repository altogether.

That’s fine I’ll disable the repository but if you know, please let me know why I don’t need that repository and whether I’ll still get the kernel updates for my kernel in the future. Also should I not just remove the repository then?

It all boils down to what you want.

If you are using the fedora kernel then you do not need that repo at all, and removing it as you showed would be best.
If you want to use that kernel from the 3rd party repo then you do need that repo installed and enabled. It does not have to be enabled full time, but would at least have to be enabled when trying to download a kernel update.

So you really have 3 options.

  1. remove the repo sudo rm /etc/yum.repos.d/mpb-fedora.repo which uninstalls it permanently.

  2. leave it installed and active → do nothing

  3. disable the repo and only enable it when you want a kernel update.
    sudo dnf --set-disabled mpb-fedora or sudo dnf --disable mpb-fedora (both of which do the same). The repo will still be installed but marked as inactive.
    Then when you want a kernel update add the option--enablerepo=mpb-fedora to your dnf upgrade command line. This option temporarily enables an otherwise disabled repo on the system.

How you manage that is entirely up to you and what you want to do or use as kernels.

Be aware that when using 3rd party kernels (and other software) that there may be issues with conflicting packages and software versions, particularly when trying to do a full system version update. There also may be issues with drivers that do not match the installed kernel and libraries. Again, that is your choice.

Mmhh. I suppose I would ask then do I need to use that kernel for my hardware to work? lol All I want is for Fedora to work properly on my laptop. If I can just be using the normal fedora kernel then I’d rather just do that.

But… anyway I think I’ve stuffed up. I did a full installation of Fedora and to go back to Mac will be a big hassle from recovery mode.

Lol was just reading this:

lol had to read it about 5 times to understand it. I had just realised I don’t have any wifi lol. I don’t have wifi anyway at home just connecting on hard wire to my phone. But from what I understood from that is that I’d need to run a script on mac os and then again on linux to get my wifi working.

Unless you have some wizard like skills and can tell me how I can get the wifi working (without going back to mac os) I suppose this post should just close.

I was taking a big gamble anyway trying to get Fedora on my mac.


P.s Lol your making me think maybe I could have installed Fedora the normal way with a normal iso from the fedora website.

lol it took me all day to do what I did today. I had to download an iso which was in parts then combine and unzip it and then make the iso. lol took me so long to work out how to do that.

I might give that a try. Installing with an iso from fedora. I followed this:

thinking it was the only way. Maybe it is I don’t know much.

Just re read your last post a couple more times. Thank you again for your time and help. Your explanations were very helpful and I learnt from you, so thank you!

I don’t know about the need for that kernel. I don’t have, never have had, and probably will never have a mac.

You will have to figure out the need for yourself. I do know that apple has made specific changes to hardware used in a mac so users are limited in what they can do with a macbook.