M.2 second drive 'lost&found' file


I have 2 m.2 drives and the second one have ‘lost&found’ file and I cant delete it. I tried using terminal to delete it nothing happend. Then I tried format it and delete everything still the file ‘lost&found’ is there. The file is 933.3 Gb and it using most of the capasity.

need help

Is this an old drive or one newly purchased? There are swindlers selling drives that claim to have a great capacity but actually contain a small USB key.

Normally there is a lost&found directory.
Can you show us ls -ld lost&found? If the drive has failed you may want to destroy it rather than wasting time on a dead drive.

The Disks utility in Fedora has a section “SMART Data & Self Tests”. Fedora also provides smartmontools which can be used to view some drive’s internal diagnostic and test results. Major vendors provide diagnostics, but they may only run in Windows. How to Check SSD Health in Linux uses Ubuntu, but once you have installed the Fedora package the instructions should apply to most linux distros.


its a new drive. Corsair MP600 PRO NH (EIFM51.1) 1TB.

here it is

drwx------. 2 root root 16384 Feb  8 21:15 lost+found

it shows that the file 16.4 kB in size, so near to nothing.
All seems fine.

Try to re-partition and re-format the problematic drive.
If this does not work, the drive is most likely bricked.

1 Like

A directory is a file. 16.4 kB means the directory contains lots of files “rescued” from a corrupt filesystem. You need to figure out what corrupted the filesystem. Likely reasons include linux crashing or losing power while writing data to the filesystem, a broken or fake (e.g., advertising a higher capacity than the drive hardware supports) drive, or malware.

Unless you are confident the corruption resulted from a non-reproducible event (power failiure or system crash) you should try to run the vendor’s diagnostics. If you think the corruption is explained by an event unlikely to reoccur, and don’t need the data, you should be able to use Gnome DIsks or similar tools to reformat the drive.

Now its fine. Re-partition and re-format did it.

thank you everyone


Now I cant make a file in that m.2.

I can only make files via Terminal. I used gparted for format.


1 Like

thank you so much

its fix