LUKS Group doesn't show up

Hello,
I switched from arch linux to fedora recently. On arch I had an LVM on LUKS setup.
During the partitioning setup on fedora, I unlocked the LUKS container nvme1n1p3 and ticked reformat on everything and set the correct mount points to the same configuration as my arch linux setup, I had another LUKS container on nvme1n1p4 for games and files but I left it untouched in the setup.
Once installed, everything worked fine.
Once booted, I used cryptsetup to open /dev/nvme1n1p4, and the passphrase is correct, but no group shows up, so there is no ArchLegionGroupData(the name I set for the group in this LUKS container when I was on arch).

Here is lsblk:
zram0 252:0 0 8G 0 disk [SWAP]
nvme0n1 259:0 0 476.9G 0 disk
└─data2 253:5 0 476.9G 0 crypt
nvme1n1 259:1 0 931.5G 0 disk
├─nvme1n1p1 259:2 0 1G 0 part /boot/efi
├─nvme1n1p2 259:3 0 1G 0 part /boot
├─nvme1n1p3 259:4 0 250G 0 part
│ └─luks-86aff68d-1e9f-4b32-af00-1e8f834124f5 253:0 0 250G 0 crypt
│ ├─ArchLegionGroup-root 253:1 0 100G 0 lvm /
│ ├─ArchLegionGroup-swap 253:2 0 16G 0 lvm [SWAP]
│ └─ArchLegionGroup-home 253:3 0 133.7G 0 lvm /home
└─nvme1n1p4 259:5 0 679.5G 0 part
└─data1 253:4 0 679.5G 0 crypt

If I boot from an arch ISO, everything shows up correctly, so it must be something different between both of them but I have no idea what it is.
What confuses me more is that the system boots so the LUKS container where root and home are located is fine but the other ones like nvme1n1p4 and nvme0n1 don’t work.

Also tried:
sudo vgcreate ArchLegionGroupData /dev/mapper/data1

Physical volume ‘/dev/mapper/data1’ is already in volume group ‘ArchLegionGroupData’
Unable to add physical volume ‘/dev/mapper/data1’ to volume group ‘ArchLegionGroupData’
/dev/mapper/data1: physical volume not initialized.

Sorry for any wrong terms used.

Latest LVM uses a whitelist of devices that are scanned located in /etc/lvm/devices/system.devices. Because the other VG was not visible during installation (was on a locked LUKS) it was not added to it. Run sudo lvmdevices --adddev /dev/mapper/data1 to tell LVM to also scan it for VGs.

Thanks, after adding and rebooting everything showed up correctly in lsblk.

1 Like