Logitech Unifying Receiver problems since Fedora 30 upgrade

I have a ThinkPad T450s which has been working flawlessly in Fedora 29. Since upgrading to 30 the other day, the Logitech Unifying Receiver USB dongle which I use for my wireless trackball sometimes stops working, and resumes working if I remove the receiver and put it back in a USB port. Looking at dmesg I get the following:

[32436.197519] usb 2-2: USB disconnect, device number 17
[32436.463338] usb 2-2: new full-speed USB device number 18 using xhci_hcd
[32436.577424] usb 2-2: device descriptor read/64, error -71
[32436.799477] usb 2-2: device descriptor read/64, error -71
[32437.015412] usb 2-2: new full-speed USB device number 19 using xhci_hcd
[32437.129374] usb 2-2: device descriptor read/64, error -71
[32437.351443] usb 2-2: device descriptor read/64, error -71
[32437.453554] usb usb2-port2: attempt power cycle
[32438.081449] usb 2-2: new full-speed USB device number 20 using xhci_hcd
[32438.081624] usb 2-2: Device not responding to setup address.
[32438.285549] usb 2-2: Device not responding to setup address.
[32438.493352] usb 2-2: device not accepting address 20, error -71
[32438.607446] usb 2-2: new full-speed USB device number 21 using xhci_hcd
[32438.607620] usb 2-2: Device not responding to setup address.
[32438.813384] usb 2-2: Device not responding to setup address.
[32439.021394] usb 2-2: device not accepting address 21, error -71
[32439.021498] usb usb2-port2: unable to enumerate USB device

I don’t know where to go for anything more informative, if it’s available. I find it unlikely that the hardware coincidentally developed a fault at the same time as the upgrade, so either Fedora 30’s driver has an issue, or 29 was covering up an existing hardware problem somehow. I am going to grab another one (I have several of these trackballs on different computers) and see if that has the same problem, but I thought I’d see if anybody has any suggestions.

This happens several times a day, so it’s quite annoying, even though it is easily (temporarily) rectified with a simple replug of the receiver.

Hello @mathw: welcome to AskFedora!

Yeh—it is unlikely that a hardware fault developed during the upgrade, but I guess that is the first bit to check. Can you also try a different USB port to cover that aspect as well?

as an “Logitech Unifying Receiver USB dongle and Logitech Mouse” user I only can confirm that the device is still working after upgrade to F30.

But I notice some changes too: single click is sometimes mentioned as double click (kernel 4.x => 5.x)

one question/a hint to investigate: did you set power setting via powertop ?
you could run in one terminal “journalctl -f” and powertop in another.
go to the last but one tab called “Tunables” (reachable via TAB-Key) and trigger the related Logitech entry from “Bad” to “Good” and vice versa to see if you are able to produce the above error message in the terminal running journalctl.

if so I guess it’s an usb related kernel bug…

  • tried to google “error -71”, but didn’t found one, so far -
1 Like

It’s not the port - I tried the other one, and it worked fine for a while so I was thinking I had a faulty port, but then the same problem started happening.

I think the error code is a red herring though, over the last couple of days I haven’t seen it again.

I looked in journalctl and there’s nothing else enlightening about why it disconnects - you can see X picking up the device when the kernel brings it back, and you can see the kernel disconnecting it, but that’s the only new info compared to dmesg. I might try a Wayland session for a bit and see if that handles it any better, but this really looks like a kernel thing to me.

I haven’t yet tried my spare trackball’s receiver, I’m going to start doing that right now. It might still be a receiver issue, and I do have the ability to test that so I will do so.

1 Like

Interestingly, looking more carefully I note that if it’s in its broken state, unplugging and replugging the receiver doesn’t necessarily result in the receiver being detected as a new device. So I guess maybe it’s something to do with the USB controller.

1 Like

Sorry don’t know how to fix but…

I’ve been experiencing something like this with my Unified receiver.

It’s plugged into a monitor’s USB port, I have no reason to believe it’s faulty.

Sometimes the mouse (logitech mx2) is dead upon boot (graphical), I mean it doesn’t move. A keyboard plugged into a USB port on the same monitor is just fine.

Logging out and back in doesn’t fix it. Only pulling the receiver out and plugging back in does.

I’m positive it started before Fedora 30.

Not sure about kernel 5.0 as I’ve been using 4.20 with Fedora 29 from the start (because of my graphics).

Next time I’ll try to check system logs to see they have same error codes.

1 Like

Hello, I am also using a Logitech M705 (maybe almost 6-7 years old) and it’s working perfectly well for me. No glitches no lags, nothing at all.

I didn’t do any upgrade. I did a fresh install, hope you can do it as well and works fine.

1 Like

I received an update through Software Center for Logitech Unifying Device.

Oddly enough, I did dnf update just before receiving this update, and the terminal told me that there weren’t any updates available???

1 Like

Was this a software update or a firmware update? Gnome software does firmware updates, but dnf does not. On the command line, you can use fwup to update your firmware.

Did that solve the issue by the way?

And is there a way to install this “Logitech Unifying Device” update without Gnome (I run XFCE) does anyone happen to know?

Firmwareupdate, yes. It did solve any issue.


Answering my own question (about doing it without GNOME).

sudo dnf install fwupd
fwupdmgr refresh
fwupdmgr update

This installed an update for my Unifying receiver - which seems to be a security fix, but who knows what else might be in there.

Unifying Receiver:
Version: RQR24.06_B0030
Name: Unifying Receiver Device Update Update
Summary: Firmware for the Logitech Unifying receiver
Remote: lvfs
URI: https://fwupd.org/downloads/0afa79c32ba48db68ccb80670a24980fbf8d8d76-Logitech-Unifying-RQR24.06_B0030.cab
Description: This release addresses an encrypted keystroke injection issue known as Bastille security issue #13. The vulnerability is complex to replicate and would require a hacker to be physically close to a target.

1 Like

It may be that your unifying receiver is just a little too far from the mouse or trackball. I encountered this in cases where I plugged the unifying receiver into the desktop,(about 4 feet from the mouse, not in line of sight) and it only worked sporadically until I plugged it into a usb bridge that was only two feet away from my mouse. This was on fedora 29 and 30. Fedora 30 seems to be more sensitive than fedora 29.