Linux 5.19.4-200.fc36.x86_64 cause problem with microphone led on Thinkpad X1 Carbon gen. 9

The Last kernel update broke microphone’s led status built on the Thinkpad X1 carbon 9’s keyboard.

Led status is always off, but the button works correctly.

If I execute:
echo 1 | sudo tee /sys/class/leds/platform\:\:micmute/brightness
led turns on correctly, but If I use again the button, led go off again for ever.


5.19.6 is out now. It might be worthwhile to see if the updated kernel fixes this for you.

I’m currently on 5.19.7, but the bug is still there :slightly_frowning_face:.

1 Like

I just noticed this as well. I thought it was an issue with a Bluetooth mic but not I’m not so sure.

Main audio mute light works fine, just the mic mute light isn’t working.

1 Like

Listing the triggers using the sys file system I can see this:
... rfkill-none audio-mute [audio-micmute] rfkill0 ...

So here it seems all ok.

Just for testing, I tried to overwrite this kernel object, selecting a new trigger associated to the led: “audio-mute”.

Now When I press the mute button, the micmute bottom “works”: it turns on and off correctly together with the mute button.

So, the problem is only with the “audio-micmute” trigger.

This has recently stopped working for me as well. I’m running 5.19.9-100.fc35.x86_64 and the same generation carbon.

1 Like

I’ve reported this at 2134824 – Recent kernels cause problem with microphone LED on Thinkpad X1 Carbon gen. 9

1 Like

Kernel version: 6.0.8-200.fc36.x86_64
The problem is still here.

I have the same problem with my Lenovo Thinkpad E15 Gen2.

Before I switched to Linux, I also had constant problems after Windows updates. I think this is a general problem with certain Lenovo notebooks. It is not necessarily system or distribution dependent. Sometimes it even went so far that I had no sound on my internal speakers.

That the problem was caused by the sound driver turned out to be a wrong conclusion in the end. I was always able to fix the problem by reinstalling the Hotkey Features Intergation driver from Lenovo’s site.

Unfortunately, Lenovo does not offer the driver as a Linux version.

Maybe there is an unofficial way to install the proprietary driver?

In Linux Mint all work fine. Currently, I have this problem only with Fedora.

I also tried to update to Fedora 37, but the problem persists.

I can confirm that on Ubuntu derivates like Mint, the feature works. However, Mint uses an older kernel than Fedora. On Manjaro it also worked fine with LongTermSupport kernel installed. The problems started with the newer kernels.

For example, openSUSE Tumbleweed is currently a total disaster for my laptop. None of the hotkeys work there anymore.