Laptop screen won't turn back on after lid closed on fresh install of F36

I have a razer blade laptop running fedora 36. I recently updated and was having problems, with the screen not turning back on after I put the laptop in suspend. After a while I bit the bullet and reinstalled fedora, thinking that would solve my problems in full. Unfortunately, that was not the case and I still have this problem. What should I do? (What diagnostic info helps you help me?)

Would you mind sharing the output of inxi -MCG ?

Hi @andras How do you suspend the laptop? Close the lid? Sometimes laptops wake up when closing and opening again.

  Type: Laptop System: Razer
    product: Blade 15 Base Model (Early 2020) - RZ09-0328 v: 5.04
    serial: <superuser required>
  Mobo: Razer model: DA550 v: 4 serial: <superuser required> UEFI: Razer
    v: 01.02 date: 04/13/2020
  Info: 6-core model: Intel Core i7-10750H bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 900 min/max: 800/5000 cores: 1: 900 2: 900 3: 900
    4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile / Max-Q Refresh]
    driver: nouveau v: kernel
  Device-3: IMC Networks USB Camera type: USB driver: uvcvideo
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell v: 42.2 driver: gpu: i915
    resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.0.3

no, unfortunately that doesn’t work for me

@andras On this site a discussion about closing the lid and suspend. English Community-Lenovo Community
It seems from there closing the lid is not always suspending the laptop. Maybe it is not (only) a Fedora issue but a hardware issue?

I’m not sure what you mean by hardware issue. When I use windows on the laptop (seperate drive), it works perfectly.

Let me clarify my problem: I close the lid, or select suspend from the top right corner, and the laptop, as far as I can tell, does enter suspend mode (fans spin down, indicator LED turns from green to white, to indicate suspend). Then if I open the lid again, the fans spin up, the led turns from white to green, but nothing else happens. The screen stays dark. I have to long press the powerbutton, to restart the machine and log in to fedora again.

@andras I did find, It is a bug, 2080742 – Cannot wake from sleep with laptop internal keyboard and power button.

I agree that it doesn’t seem like a hardware issue, but appears to be a bug with the Intel graphics driver. Most likely, it will be fixed in a kernel update. It looks like you have an nVidia card as well. It’s also possible to run fully off the nVidia card, though that would mean more power consumption.


How could I do that?

There are two options I know of:

  1. If your BIOS supports enabling/disabling integrated graphics, then change your BIOS setting to run on discrete. This should effectively disable the integrated graphics. Not all BIOS’ include this option. Sometimes it is worded as “Optimus” support, etc.

  2. Run on X and set X to run on the nVidia card as a the primary GPU:
    Check out @computersavvy’s helpful advice for how to do that in the comment here:

1 Like

I am having doubts that the nvidia driver correctly installed. I installed it according to the RPM fusion Howto, and modinfo -F version nvidia outputs, that I have version 510.68.02 installed, but /etc/X11/xorg.conf.d/nvidia.conf doesn’t exist. Is there an easy way to check, if the driver is installed, and if it works?
(also, i just uninstalled/reinstalled it, so it should work, and I am in xorg, not wayland/regular gnome)

You’ll want to create that file with vim (or your favorite text editor) as sudo or root.

So it’s not supposed to already exist? A config file with a single line? Only cause the way it was worded in that post (“a slight change”), I expected a file to already exist.