Laptop display stays blank using fedora 34 kernel 5.12, but works with 5.11

since update to kernel 5.12 on fedora 34 my laptop display stays blank after some boot messages. An external screen works fine. When I boot kernel 5.11 both displays work.
The graphics card is a “Intel Corporation UHD Graphics 620 (rev 07)” .
I searched for any warnings or errors in boot messages but got no luck.
Since this is my first post here, I haven’t found the upload/attach function yet to add the boot messages of both kernel versions.

Can you test with the kernel boot parameter “nomodeset” ?

Hi Sampson,
thanks for your reply
with nomodeset the laptop display works, but the external monitor doesn’t

So, you got:

default boot: LCD blanked while external monitor works
nomodeset: LCD works while external monitor blanks

You create each a boot entry, so that you can choose which one to boot while troubleshooting this issue.

Can you try the newer kernel 5.13.6, 5.13.7 or even 5.13.8 ?

Hi Sampson,
excuse my delayed answer. Have been away for some days.
For kernel version 5.13… you are right

default boot: LCD blanked while external monitor works
nomodeset: LCD works while external monitor blanks

Kernel version 5.11 works fine.
I will just add the “nomodeset” or other needed kernel parameters at boot, no problem.
Kernel version 5.13.6 behaves like writen above, version 5.13.7 is currently being installed and I will try at once. Where/how do I get 5.13.8?

tried 5.13.7, behaves like the other 5.13.x. Still LCD blanked and external monitor fine when booting default, with nomodeset LCD works but no external monitor.
Using default boot the LCD is blank, but in gnome display settings it is recognized as first screen and as long the lid is open, it is the main screen with application choosser etc.

1 Like

Now I got 5.13.8, but same as before.


Same problem here, or almost the same.

Laptop display not working with 5.12 and 5.13 kernels. Funny thing is that a monitor connected over hdmi is working.

HP ProBook 450 G7, I7-10510U CPU, Nvidia GeForce MX250 OS: Fedora release 34 (Thirty Four)

I installed Nvidia drivers using autoinstaller from here: but no success, the problem still manifest in 5.12, 5.13 kernels but no in 5.11.
nomodeset get me just a blinking cursor.

Same here, from kernel > 5.12 (including 5.13.9) the Intel UHD Graphics 620 (rev.2) stays blank after boot:

  • Laptop screen blank
  • External HDMI monitor works fine
  • Same behaviour booting with X or without (no graphic session)
  • adding “nomodeset” in kernel parameters, laptop screen works (but only 1024x768 resolution) but external monitor doesn’t get recognized
  • If I boot with kernel 5.11.12, all works fine
  • Same i915 drivers loaded in both kernels (lsmod is the same in both kernels)

Using Fedora 34

1 Like

Any news on this?
Currently I’m using kernel 5.13.12 and it’s still the same issue

1 Like

I also have this Problem with the HP Probook 450 G7 since kernel upgrade to 5.12.
I am still running on 5.11.
I tried a couple of things like installing Nvidia driver BIOS update etc. but wit no success.
In the Xorg.log I only see this error messages:

Xorg.0.log.old:[ 197.460] (==) No screen section available. Using defaults.
Xorg.0.log.old:[ 197.467] (EE) no screens found(EE)

It would be great to get a solution for this.

1 Like

I think, for those with the nvidia GPU in their laptop, that the solution may be very simple.
There is a file /usr/share/X11/xorg.conf.d/nvidia.conf that is installed when you install the rpmfusion nvidia drivers. The package containing it is xorg-x11-drv-nvidia. It seems the default is for the IGP to handle the laptop screen and the discrete GPU (nvidia) to handle the external monitors but since only one of the GPUs can be active at a time the default gives an either-or scenario.

If you were to copy that file to /etc/X11/xorg.conf.d/nvidia.conf then reboot I suspect the problem with only the external display working would be solved.

IIRC the line within the Server Layout stanza that says

Option "AllowNVIDIAGPUScreens"

will fix the problem as it allows the nvidia GPU to drive all outputs and not just the external monitors.

thanks for your response.
I installed the Nvidia driver like written here: Howto/NVIDIA - RPM Fusion
And I have copied the nvidia.conf as you wrote:

[root@HKT20067 xorg.conf.d]# ll /etc/X11/xorg.conf.d/nvidia.conf
-rw-r–r–. 1 root root 333 Sep 5 13:44 /etc/X11/xorg.conf.d/nvidia.conf

I rebooted to start a newer kernel but with no success.
I still have the problem with a blank screen, and only a fast blinking cursor on the internal display.
In addition I have to add “nomodeset” to the grub boot commandline, otherwise nothing is shown.
Best regards,

i even disabled the NVidia video card, and run just on Intel video card, but the simtoms are the same, black screen when booting kernel version bigger than 5.11

I have the same issue with my work laptop, HP ProBook 450 G6 with UHD 620, and maaan, it’s has been a couple of months already and this is not fixed.
Fortunately I have an external display which still works and don’t have to use tricks like use an older kernel.

This is really bad publicity not for Fedora but Linux in general.
Would a LTS kernel saved Fedora from this? I dont 't know.

This seems to be on Intel side. There were some patches but some users(like us) still have experience this issue. We should probably all start complaining there.

1 Like

Have either or both of you done a full upgrade?

sudo dnf upgrade --refresh
sudo dnf distro-sync

Have you tried copying/usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf then restarting?

@computersavvy It is not related to Nvidia in my case. HP ProBook 450 G6 is Intel only. And yes my system is updated.

I am also having the same issue on a HP elitebook 840 g5 under kernels 5.12.x and 5.13.x but it works under 5.11.x and previous versions. This is with intel graphics not NVIDIA. The system has been fully upgraded also.

I also did a full system upgrade.
Today I updated to kernel 5.13.14-200.fc34.x86_64 but the problem is still there…

Fully updated today and tried 5.13.14-200 but same as before. Only working kernel is still 5.11.12 for me.