Lags when i play something

Hi there!

I’m new to linux and i have a problem with my fedora 39. When i play something (Baldurs Gate 3 or The Witcher 3 ) my pc goes wild. I cant open any program, it can eventually just freeze and then i can do nothing but just reboot it. I have a decent pc. its not something very expensive:
CPU: R5 5600G
RAM: 2x8gb Kingstone 3200
Motherboard: MSI B500A Pro
My Fedora is installed on SSD
Games are on a M.2 drive

I just dont understand WHY? I know that i run it through Proton (8.0-4)… but its not supposed to be like that.

UPD: Recently, while playing The Witcher 3 had a crash and sda3 (which is my main partition) error.
Reinstalled my whole system on my m.2 drive. I think this whole situation was because my ssd was only like 120 gb. Will test things today
UPD2: The problem seems to be solved… now it runs perfectly and without crashes/lags and so on.
The problem was with my ssd as i think, but im not sure

Sorry for my english btw, its not my first language

If you need more specs:

  Kernel: 6.6.6-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 Desktop: GNOME v: 45.2 Distro: Fedora release 39 (Thirty
  Type: Desktop Mobo: Micro-Star model: B550-A PRO (MS-7C56) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.B0
    date: 08/11/2022
  Info: 6-core model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 3148 high: 3696 min/max: 400/4464 cores: 1: 2954 2: 2953
    3: 2954 4: 2953 5: 3693 6: 2954 7: 2951 8: 3068 9: 3696 10: 2955 11: 3692
    12: 2953 bogomips: 93427
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: RDNA-1 bus-ID: 12:00.0
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel arch: GCN-5 bus-ID: 30:00.0 temp: 32.0 C
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.2 driver: X:
    loaded: amdgpu unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi
    gpu: amdgpu resolution: 2560x1440~60Hz
  API: OpenGL v: 4.6 vendor: amd mesa v: 23.2.1 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 5700 XT (navi10 LLVM 16.0.6 DRM
    3.54 6.6.6-200.fc39.x86_64)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
    bus-ID: 12:00.1
  Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 30:00.1
  Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 30:00.6
  Device-4: Logitech G535 Wireless Gaming Headset
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid type: USB bus-ID: 1-6:3
  API: ALSA v: k6.6.6-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: e000 bus-ID: 2a:00.0
  IF: enp42s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.13 TiB used: 337.26 GiB (29.1%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P3PSSD8 size: 931.51 GiB
    temp: 28.9 C
  ID-2: /dev/sda vendor: Patriot model: Burst size: 111.79 GiB
  ID-3: /dev/sdb vendor: SanDisk model: USB 3.2Gen1 size: 114.61 GiB
    type: USB
  ID-1: / size: 110.2 GiB used: 37.26 GiB (33.8%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 344.7 MiB (35.4%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 110.2 GiB used: 37.26 GiB (33.8%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 40.1 C mobo: N/A
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 33.0 C device: amdgpu temp: 51.0 C fan: 0
  Processes: 461 Uptime: 4m Memory: total: 16 GiB note: est.
  available: 13.54 GiB used: 3.56 GiB (26.3%) Init: systemd
  target: graphical (5) Compilers: gcc: 13.2.1 Packages: 19 note: see --rpm
  Shell: Bash v: 5.2.21 inxi: 3.3.31

Please note that I edited your post and added the preformatted text tags with the </> button on the toolbar so the output from inxi is displayed as formatted on-screen. When posting text that you copy&paste from your screen please use this method to retain formatting and make things easier to read.


I don’t see anything in what you posted that might indicate a reason for a lag.

I assume you are using steam. If so then be aware that as yet steam is only using 32 bit so the proton config within steam may be the cause. For some games I have to specify the proton version to use.

Admittedly proton is fault free. could be incompatibility. I would think contacting proton system directly and see if the machine using is in need of some upgrade.