Keyboard not working on Asus Vivobook OLED S5402ZA

I bought a new Asus Vivobook OLED S5402ZA and the keyboard does not work in Fedora 36 (Grub, Fedora). The keyboard works in Bios and some function keys work in Fedora.

I have tried many things as advised in various platforms:

  • Added boot options (i8042 reset etc)
  • Fastboot + Secure boot disabled
  • Enable/Disable intel vbtn
  • Tried vanilla mainline kernel (5.19)

No luck so far, the keyboard is not recognized at all. If you guys have any suggestions left, I would really appreciate it. I rather use a USB keyboard than going back to Windows.

Problem is reported for other Linux distro’s as well:

Without having the named machine to test this is only a guess, but it seems the keyboard controller is non-standard and thus cannot be managed by the OS.

Does it not work when booted from the live USB? or only have the problem from the installed OS?

Remember that microsoft is working hard with the vendors to create devices and software that work seamlessly for their own OS, and they don’t care (or maybe it is deliberate) if they break hardware access for another OS like linux.

Thanks for your reply. The keyboard does not work in live USB either. Asus is pushing these machines hard, so hopefully they become so common that some fix will arrive one day.

I answer my own question, it may help others :). It turned out to be a kernel bug around IRQ interrupts.

Should be available in 6.1. Easy to fix earlier by applying the patch (and add your laptop type to drivers/acpi/resources.c, then recompile kernel)