Kernel mitigations in Silverblue

How do I toggle the kernel mitigations in silverblue?

sudo rpm-ostree kargs --append=mitigations=off adds it permanently try the man pages

Still does not work

 ~ rpm-ostree kargs 
resume=/dev/mapper/fedora-swap rhgb quiet root=/dev/mapper/fedora-root ostree=/ostree/boot.1/fedora/63603c79a7021bb850361f6f18f5249560fbdde095452aadbe2136913bbc47ff/0 mitigations=off
~ journalctl -b -1
Nov 12 14:46:39 localhost kernel: Linux version 5.3.9-300.fc31.x86_64 ( (gcc version 9.2.1 20190827 (Red Hat 9.2.1-1) (GCC)) #1 SMP Wed Nov 6 16:13:19 UTC 2019
Nov 12 14:46:39 localhost kernel: Command line: BOOT_IMAGE=(hd0,gpt2)/ostree/fedora-63603c79a7021bb850361f6f18f5249560fbdde095452aadbe2136913bbc47ff/vmlinuz-5.3.9-300.fc31.x86_64 resume=/dev/mapper/fedora-swap rhgb quiet root=/dev/mapper/fedora-root ostree=/ostree/boot.0/fedora/63603c79a7021bb850361f6f18f5249560fbdde095452aadbe2136913bbc47ff/0

Is the boot config rebuild required? If so, what is the Silverblue way to do it?

Got it. I restarted and no change happened then, I saw grub had replicated boot entries. Booted the second replica and it had the configured kernel parameters.
And so did all other reboots later on.

Btw sudo is not required.

And to get to the hidden grub menu, in gnome restart dailog press alt and boot options will popup instead of restart. (Kinda like Android advanced restart).

That’s strange for me the boot menu always appears.
The duplicated entries are fixed in some recent version of something.

But adding the kargs the entry with the args should have been the top one, maybe this is some (fixed in newer?) bug?

Nah, it’s not fixed for me. I thought the same before,
I am using silverblue as my main since F28 and had that iso installed but duplicated boot entries got irritating so cleaned my drive and reinstalled the F31 iso again, unfortunately the problem still exists.

Btw the grub menu should be hidden, it’s a change that shipped in F28. (You must be having multiple OS Dual boot)

Btw i noticed one bug… if i don’t go to grub menu and select the entry from there and upgrade some packages and reboot then kargs are applied.

I am dumb, everything is working great.
I ran journalctl -b -1 instead of journalctl -b that gave me the logs of previous boot.