Kernel 6.3.11 vs rtw_8821ce

Olá pessoal.

Após atualizar meu fedora 38 para o kernel 6.3.11 percebi um flood de “rtw_8821ce 0000:02:00.0: firmware failed to leave lps state” pelo journalctl -f, após perceber que o sistema estava com um consumo exagerado de cpu por parte deste processo (100% de cpu).

O problema está relacionado a placa rede sem fio Realtek 8821CE, que por alguma razão não consegue deixar o modo de economia de energia (LPS - Low Power State).

Tentei algumas coisas como limpar o log do journalctl e diminuir o tamanho e depois recarregar o modulo, mas sem sucesso. Tentei também desativar o modo de baixo consumo criando um arquivo de configuração em /etc/modprobe.d/rtw_8821ce.conf, com a instrução “options rtw_8821ce ips=0”, também sem sucesso.

Será que já existe algo relatado sobre isso para correção?

obs: Retornando ao kernel 6.3.8 não há esse comportamento. Porém acontece o erro “rtw_8821ce 0000:02:00.0: failed to send h2c command” esporadicamente.


I have the same issue not solved with

“options rtw88_core disable_lps_deep=y”
“options rtw88_pci disable_aspm=y”

Thanks for share the issue in bugzilla. I’ll try this ones options too and wait to new versions to fix the problem. :+1:

In case it’s works I say here.

1 Like

In my case setting de options do not worked.

Only modules of kernel 6.3.8 work fine.

Parece que na versão 6.3.13 teremos correção:

commit 22909742080e1f1af508941744e613c8f8101a01
Author: Sascha Hauer
Date: Wed May 24 12:39:34 2023 +0200

wifi: rtw88: usb: silence log flooding error message

[ Upstream commit 1f1784a59caf3eefd127908a1a3cf224017ff9c7 ]

When receiving more rx packets than the kernel can handle the driver
drops the packets and issues an error message. This is bad for two
reasons. The logs are flooded with myriads of messages, but then time
consumed for printing messages in that critical code path brings down
the device. After some time of excessive rx load the driver responds

rtw_8822cu 1-1:1.2: failed to get tx report from firmware
rtw_8822cu 1-1:1.2: firmware failed to report density after scan
rtw_8822cu 1-1:1.2: firmware failed to report density after scan

The device stops working until being replugged.

Fix this by lowering the priority to debug level and also by
ratelimiting it.

Fixes: a82dfd33d1237 ("wifi: rtw88: Add common USB chip support")

now to wait release fedora update :slight_smile:

Recent updates don’t fixes problem


One may visit the Linux Hardware Database and probe their own computer to see if the device is properly supported and running. Or they may use the site to see what others have found about that particular card by searching with the full chipset id which can be found with lspci -nnk then putting the two parts of the id together.
On my system that gives this

05:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz [8086:2725] (rev 1a)
	Subsystem: Intel Corporation Wi-Fi 6 AX210 160MHz [8086:0024]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

and the full chipset id is 8086:2725:8086:0024

Thanks jeff V!

My hardware probe

I had a qualcom card that had worked well for several years, then all at once it began having problems remaining connected and caused a lot of cpu issues as a result. I replaced the card with the one I noted in the post above and the problems quit. This began about the time of the upgrade from kernel 6.3 to 6.4.

Maybe a similar issue is happening with your adapter – failing now. Sometimes software upgrades reveal bugs (maybe in the driver or firnware) that previously were dormant/unknown.

do you think realtek will drop driver maintenance? Did you replace by changing the board card?

While I doubt that realtek will drop support for linux, it is a fact that devices do sometimes fail, and not always as one would expect.

My original adapter was PCIe in my desktop but the mobo had an M.2 slot for wifi adapter so I removed the PCIe adapter and installed an M.2 adapter instead. I believe laptops all use an M.2 adapter in a position where it is really easy to replace them.