KDE Discover shows only Flatpak apps


Hello, recently I tried to install Fedora Plasma Spin and saw one problem. KDE Discover was showing only apps from Flathub. I saw some other themes about that but problems is not solved there. So i am asking your help
I saw that some apps are shown, such as GIMP or qBitTorrent. But for example Krita or TimeShift are not there. What I am doing wrong?)

Welcome to ask.fedora @farline99

Did you add the RPM Fusion
Configuration - RPM Fusion

Hi, yes, I enabled RPM Fusion and installed metadata with this instruction.

pkcon refresh force

to update the metadata for discover. You may need to reboot after this just to be safe.

Just to double check you can also search from the command line:
sudo dnf search <application/package name>

Searching for krita and timeshift on my machine with dnf shows them as available.

If updating the metadata does not provide the packages and searching with dnf works, I’d suggest filing a bug


Thank you for answer, but updating metadata didn’t help. DNF is working fine and could search krita or timeshift without problems, but discover… It can’t see them also if I install them and try to check in “installed” column :frowning: Will write bug to Red Hat bugzilla I guess.

1 Like

What do your enabled sources look like in Discover? Can you share a screenshot?