KDE Connect in Kinoite

Hi all, I am having difficulty using KDE Connect in Kinoite.

I installed the flatpak from https://distribute.kde.org/kdeapps.flatpakrepo

I also have KDE Connect running on my phone and I can successfully pair my phone to my laptop. But when I try to send the file from the phone to the laptop, the file does not appear anywhere on the laptop. I think it’s supposed to go to the Downloads directory but it’s not there. The phone says it successfully sent the file.

Another weird issue is that I can’t seem to actually open the KDE connect app on the laptop, I can see the icon in the tray next to my clock but when I click on it all that happens is the laptop freezes for about 5 seconds, then the app displays on the screen for about half a second then disappears. If I right-click on the icon, I do not get any menu.

Another weird issue is that if I click on a file in Dolphin and select “send to device” I get the following error:

Failed to load the configuration page for this action: file:///usr/share/purpose/kdeconnectplugin_config.qml:11 module “org.kde.kdeconnect” is not installed

Any ideas how to fix this?

If you haven’t given the flatpak access to your home directory it will write the data into it’s sandboxed directory. It should be on the machine though if you browse for it.

Alternatively, you could use flatseal to give the flatpak access to your home directory.

KDE Connect will likely not work in a Flatpak for a while, until some support is added in Flatpak for services. We’re planning to add it to Kinoite directly (Issue #279: Kinoite: Include kde-connect by default - SIG - Pagure.io) and in the mean time you can overlay it.

1 Like

I uninstalled the flatpak and layered it and now it works as expected, thanks.

By the way there does not appear to be any way to prevent KDE Connect from automatically starting each time I boot. (it’s not listed in the autostart section of kde settings). I’m guessing the developers intentionally designed it that way but I don’t like it.

It is probably in /etc/xdg/autostart. Try this to inhibit the autostart:

touch ~/.config/autostart/org.kde.kdeconnect.daemon.desktop