Kargs change led to hang-up during boot


I was playing around with some options and performed a rpm-ostree kargs hugepages=4096. After that, when I did a reboot, boot hangs. I am unable to go to the grub menu to choose the previous version or do anything else.

Please help.


Hello @randomgeek78,
Welcome to the community!
I haven’t altered the hugepage setup on my Silverblue system, so never ran into this problem before. If you have the live USB or CD to try to boot up your system, you can drop to a shell in the live OS then maybe fix your system from there. I would be surprised if simply changing this one kernel argument caused the rollback to not work as expected.

Hi @jakfrost,

Thanks for responding. I spent the entire last 3 days figuring out just that - how can I manipulate the grub from the live-cd. I tried modifying grub.cfg in the efi, I tried chroot and some other things but the ostree setup was too complicated for me. Finally, I just gave up - keep the fight for another day when I learn some more about these things. The other thing in my mind is to try getting silverblue with btrfs to work. Again, it currently involves modifying grub kernel command parameters that I am not sure how to do yet.

The Kargs arguement is what is passed to rpm-ostree during boot by grub. If you interrupt the boot process at the menu and you can then select to edit the arguments passed to the kernel on boot. This is a one time thing, you have to repeat it every time. AFAIK, Grub2-mkconfig is still used by Grub2 on SB for making the actual grub config file. I am uncertain at this time about Grubby whihc I would normally use for modifying my boot entries. I’ll do some digging later, have to run right now,