Issues while connecting to wifi range extenders

I have issues connecting to some sites while connected to wifi range extenders (I have tp-link RE200). Some sites which give ‘ERR_ADDRESS_UNREACHABLE’ are, reddit, amazon. I dont have any issues accessing these sites when connected to my main router. This issue exists only in my laptop (acer aspire 5), not on my mobile or other devices.

I see this error in logs when connecting to my wifi extender,

NetworkManager[831]: <warn>  [1627241042.0287] dhcp4 (wlp3s0): request timed out
NetworkManager[831]: <info>  [1627241042.0290] dhcp4 (wlp3s0): state changed unknown -> timeout

Also, if i run “route” command, i see below when connected to extenders

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   U     0      0        0 virbr0

when connected to main router

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway         UG    600    0        0 wlp3s0   U     600    0        0 wlp3s0   U     0      0        0 virbr0

I am new and would appreciate any help. Thanks.

The routing is normal if you have not connected and been assigned an IP.

You say this is only with range extenders, please give more detail.

Is this with a range extender at home, and you are just further from the main AP or is this trying to connect to an AP in a different location?

If trying to connect at a different location how do you know it is a range extender and not a simple AP?

Does the situation change when you are closer to the AP / range extender or further away?

What band is this? 2.4 or 5 Ghz.
What is the displayed signal strength when attempting to connect.

If this is a range extender you control then it may be that it is not properly configured. The range extender has to be configured with the AP as master and the extender as slave for dhcp. How far is the range extender from the actual AP?

1 Like

Thanks for replying.

Extender is in First floor and the main router is in the ground floor apartment. Issue happens on both 2.4 and 5 Ghz. When connected to same range extender, my other devices (windows laptop, mobile) do not have this issue. Connection strength looks good.

Infra 11 130 Mbit/s 100 ▂▄▆█ WPA2 – 2.4 Ghz
Infra 64 135 Mbit/s 95 ▂▄▆█ WPA2 – 5 Ghz

In the extender, under connected devices my fedora laptop is shown as “UNKNOWN” with IP - I do not understand why dhcp4 times out.

If I am understanding correctly, the fedora laptop will connect directly to the main AP with no problems, but when it tried to connect via the extender then dhcp times out. It also seems the windows laptop (a different machine) and your mobile device connect with no problems.

Just to clarify a point. Are you certain the windows laptop and mobile device are connecting via the extender and not directly to the main AP? If they are then I really have no explicit idea why one would fail to connect but another would have no problems.

It is known that certain wifi chipsets do not play well with linux due to driver issues, so the first thing I would suggest is that you post the output from “inxi -Nnxx” so we can see exactly what card and driver is in use.

I guess you are missing the default gateway on your extenders.
And/or then net-mask has to be

Some pages might be work because they are in the cache of the browser.