Issue updating to Mesa 23.0

I am having an issue where Mesa 23.0 is not being installed when I update my computer. When I run dnf update --refresh --allowerasing, the output is:

Dependencies resolved.
Problem: cannot install the best update candidate for package mesa-va-drivers-freeworld-22.3.7-1.fc37.x86_64`
  - problem with installed package mesa-va-drivers-freeworld-22.3.7-1.fc37.x86_64
  - nothing provides mesa-filesystem(x86-64) >= 23.0.1 needed by mesa-va-drivers-freeworld-23.0.1-1.fc37.x86_64
 Package                   Arch   Version          Repository              Size
Skipping packages with broken dependencies:
 mesa-va-drivers-freeworld x86_64 23.0.1-1.fc37    rpmfusion-free-updates 3.4 M

Transaction Summary
Skip  1 Package

Nothing to do.

My system is running an AMD Ryzen 5700G APU and all packages are otherwise up to date. Let me know what other info I can provide about my system, and thanks for the help!

I got this error too today. Generally it is going away after a view day.
As I understood, there is a new version but there are not all dependencies ready (broken).

I still have it, I believe It might got into the beta freeze announced lately. It could take more time as normal to disappear this time.

I do not worries, because I do not see any problems with it.

@dew-or-dew-not do you see some problems with the gpu etc?

the package you need is in testing for now. you can check this here :

For Fedora 37 it’s in the testing part.

Wait until it’s ready and dnf will let you update. For the time being, our current packages will work fine.

This worked for me (just updating the missing package for testing):
dnf install mesa-filesystem --enablerepo=updates-testing,updates-testing-modular --best

after this sudo dnf upgrade

and then the missing dependencies:

 mesa-va-drivers-freeworld                        x86_64                     23.0.1-1.fc37                     rpmfusion-free-updates                     3.4 M

finally got upgraded.

Just don’t know what has to be done if the correct mesa-filesystem is in stable again?

1 Like

the packages will move from testing to stable after they are considered “ready” (tested, stable). by turning on the testing repos you might get very up to date packages but they might not be totally tested and confirmed without any side-effects (this is why we put them in testing before they move to the stable repo).

If that happens you will be able to downgrade the version of the package that is an issue, you are never really stuck.

I know how the testing repos work. The point i try to make is that:

Name         : mesa-va-drivers-freeworld
Version      : 23.0.1
Release      : 1.fc37
Architecture : x86_64
Size         : 12 M
Source       : mesa-freeworld-23.0.1-1.fc37.src.rpm
Repository   : @System
From repo    : rpmfusion-free-updates

the content of rpmfusion repo is not a officially from fedora maintained, it is a merge of different sources.
In the other hand:

Name         : mesa-filesystem
Version      : 23.0.1
Release      : 1.fc37
Architecture : x86_64
Size         : 3.6 k
Source       : mesa-23.0.1-1.fc37.src.rpm
Repository   : @System
From repo    : updates-testing

as a dependency of the above rpmfusion where is normally in updates, not got moved from testing to stable because of the freeze who we are in since (see schedule)

20 Final Freeze (starts at 1400 UTC) Tue 2023-04-04 Tue 2023-04-18 14
21 Early Final Target date

Fedora contributors plan on this|Tue 2023-04-18|Tue 2023-04-18|0|

This can also happen if we are not in a freez while rpmfusion updates earlier as the official fedora Chanel for example and this updates get replicated already to the different mirrors. Normally this is not a big thing, because within 24 hrs. the mirrors should be updated and everything should be in sync again.

(I answer to my selves)
Probably nothing happens as I not activated the testing repos. If testing get moved to stable as it is, it just will overwrite update-testing with update.

I had to update because I got a error messages while working with github-cli and the cli opened a Firefox session.

Probably just downgrade would have been the smarter moove:

sudo dnf downgrade mesa-va-drivers-freeworld

Thanks for clarification :slight_smile:

I’m gonna try to wait until it moves to stable.

The final freeze applies to Fedora 38 only, but this topic is about Fedora 37, i.e., it is unrelated.

1 Like

Just upgraded to Fedora 38 and I still have the same issue. I hope they’ll fix it soon :confused:

Do we know why this package is on hold in testing while all the other mesa packages at 23.0.2 are stable right now?

(Sorry for the triple reply, I’m learning about this subject as I’m digging deeper)

The issue seems to come from RPM Fusion actually because they promoted their “freeworld” packages to 23.0.2 although the official packages are still all at 23.0.1:

Since RPM Fusion doesn’t bring their own mesa-filesystem package, we get this conflict. Also I don’t know why RPM Fusion is in advance compared to the stable mesa packages, they should follow the stable releases normally :thinking:

I upgraded to Fedora 38 and it seems everything is resolved for me. Hope this gets resolved soon for anyone else this still affects!

Could be that your system is not in sync with F38 yet. So please do the “Using distro-sync to resolve dependency issues” part from the DOC’s I linked below.

1 Like

With fedora 38 all is good. Mesa is at 23.0.2.

The issue has been with F37 and the delay in release from testing. I expect that this particular delay is related to the amount of work involved in finalizing the release of F38 (which happened yesterday)

I have the same problem on fresh Fedora Silverblue 38.

roblem: package mesa-va-drivers-freeworld-23.0.2-1.fc38.i686 requires mesa-filesystem(x86-32) >= 23.0.2, but none of the providers can be installed
  - conflicting requests
  - mesa-filesystem-23.0.2-2.fc38.i686 has inferior architecture
  - package mesa-va-drivers-freeworld-23.0.2-1.fc38.x86_64 requires mesa-filesystem(x86-64) >= 23.0.2, but none of the providers can be installed
  - cannot install both mesa-filesystem-23.0.2-2.fc38.x86_64 and mesa-filesystem-23.0.1-2.fc38.x86_64

You have mismatch with the architecture i686 and x86_64 are not the same …
remove i686 package before upgrade.

but i can’t remove something that i don’t have . As i say i just installed system from 0. Nothing was doing on that installation, expect one command to install mesa-freeworld.

error: Package/capability 'mesa-filesystem-23.0.2-2.fc38.i686' is not currently requested

when i want to install x86_64

Problem: cannot install both mesa-filesystem-23.0.2-2.fc38.x86_64 and mesa-filesystem-23.0.1-2.fc38.x86_64
  - conflicting requests
1 Like

Try this:

sudo dnf list --installed mesa-*

and post the output

I have none of the mesa i686 packages installed and just performed an upgrade from F37 to F38 last night.

# dnf list installed mesa*
Installed Packages
mesa-dri-drivers.x86_64                                                 23.0.2-2.fc38                                        @updates       
mesa-filesystem.x86_64                                                  23.0.2-2.fc38                                        @updates       
mesa-libEGL.x86_64                                                      23.0.2-2.fc38                                        @updates       
mesa-libEGL-devel.x86_64                                                23.0.2-2.fc38                                        @updates       
mesa-libGL.x86_64                                                       23.0.2-2.fc38                                        @updates       
mesa-libGLU.x86_64                                                      9.0.1-8.fc38                                         @fedora        
mesa-libgbm.x86_64                                                      23.0.2-2.fc38                                        @updates       
mesa-libgbm-devel.x86_64                                                23.0.2-2.fc38                                        @updates       
mesa-libglapi.x86_64                                                    23.0.2-2.fc38                                        @updates       
mesa-libxatracker.x86_64                                                23.0.2-2.fc38                                        @updates       
mesa-va-drivers-freeworld.x86_64                                        23.0.2-1.fc38                                        @rpmfusion-free
mesa-vulkan-drivers.x86_64                                              23.0.2-2.fc38                                        @updates