Is there a way to use this NVMe without switching RAID to ACHI?

This message was in journalctl:

Nov 02 06:44:49 FedoraStick kernel: ahci 0000:00:17.0: version 3.0
Nov 02 06:44:49 FedoraStick kernel: ahci 0000:00:17.0: Found 1 remapped NVMe devices.
Nov 02 06:44:49 FedoraStick kernel: ahci 0000:00:17.0: Switch your BIOS from RAID to AHCI mode to use them.
Nov 02 06:44:49 FedoraStick kernel: ahci 0000:00:17.0: AHCI 0001.0301 32 slots 16 ports 3 Gbps 0x0 impl RAID mode
Nov 02 06:44:49 FedoraStick kernel: ahci 0000:00:17.0: flags: 64bit ncq sntf pm clo only pio slum part deso sadm sds apst

The BIOS warns that switching to AHCI from RAID will destroy the existing Windows install on the NVMe. I don’t think that is true, because it is just one drive, not using any RAID features. But I’m not sure.

00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode]
        Subsystem: ASUSTeK Computer Inc. Device 1c71
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 16
        Memory at c4290000 (32-bit, non-prefetchable) [size=32K]
        Memory at c42ac000 (32-bit, non-prefetchable) [size=256]
        I/O ports at 4090 [size=8]
        I/O ports at 4080 [size=4]
        I/O ports at 4060 [size=32]
        Memory at c4200000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

Windows has many ways to destroy an existing install, and can add news ones at any time. With or without linux, you need to be able to restore Windows from backups.

I expect this to be true. This is because RAID access changes the layout of the disk. RAID will put meta data in the disk to manage the RAID configuration.

1 Like

I think this simply means that the first boot after the switch will often require using a windows recovery boot method. I have not tested with windows 11 and understand the process there may be more restrictive than with windows 10.

I was hoping there was a Linux driver for this RAID controller, so I wouldn’t need to switch modes.

But I created Windows recovery media today (I didn’t have a large enough USB stick until recently). Now I’m running a full backup to be extra safe. Then I’ll see what changing modes actually does.

I have a Linux bootable USB that I use for various emergency situations on multiple Windows systems. Other systems (with the same RAID controller) may not be practical to switch out of RAID mode, so having a driver would be more effective.

1 Like

There is a linux driver for Intel BIOS RAID. I use it all the time.

BUT to use RAID means that you end up formatting the disks with the
metadata for the RAID. That will corrupt what is already on the disk.

How many disks are do you want to put into the RAID?

This one is a laptop that only supports one SSD drive.

Once I had good enough backup, I tried switching to AHCI mode and there was no problem. Despite the warning in the BIOS, nothing stopped working. There was no need to repair the Windows boot.

The BIOS UI still implies the RAID mode is faster than the AHCI mode. I haven’t figured out a good comparison test.

I don’t think you mean the same thing I meant. But in case you do, what driver do you mean?

It is confusing: It is a RAID controller but not doing any RAID, yet that is still different from AHCI mode.

BIOS RAID Support is built into the linux kernel is what I meant.

With lots of ignorance, I was able to install F38 along side W10 on a Lenovo laptop with Optane (raid) system. I got the laptop not knowing that it had Optane. When I tried to install F38, the ssd was not visible and the F38 installer told me that I had to disable Optane in the BIOS. I jumped right in and disabled it, but could not change RST to ACHI. F38 installed just fine using the “standard” install (ext4 partitions) under the “custom” install options. I had everything backed up and was prepared to reinstall W10 if necessary. So, I wasn’t worried about the warning which I did get. I did not re-enable Optane and actually reformated the ±28gb Optane storage area to ext4 so that I can use it for something if I decide to. So far, all is working well. RST has not caused any issues that I’m aware of including Windows . Hope this help a little.