Is there a correct way to set up system clock on dual boot configuration?

I have a laptop with a Windows 11 & Fedora dual boot configuration and, possibly because of this kernel behavior, the clock always become skewed after suspends. I have tried running timedatectl set-local-rtc 0, which substituted this problem with another one where Windows doesn’t show the correct time.

I know there is a way to have Windows use UTC for the BIOS time by modifying a registry entry, but saw a comment somewhere that you have to also disable NTP on Windows. Is this the only solution for the problem?

Tell windows that the clock is set to UTC, web search will tell you how to do this. You do not need to disable ntp on windows.
I did not think its was a registry edit, but I srt my windows up a long time ago and do not recall how i did this.

Tell fedora the RTC is set to UTC.

Then you can boot into either fedora or windows and clock will not jump around.

1 Like