Is it possible to install the Paragon Drivers to Fedora?

I’m trying to install the (free version of) Paragon NTFS for Linux, so I can write to my HFS+ partitions. Microsoft NTFS for Linux by Paragon Software - Introduction

I’m running into 2 problems.

  1. The Paragon instructions say to log in as root.

  2. If I try to use sudo instead, I get a warning that

Current kernel version is out of supported range.

  1. If I try anyway, I get

Searching and removing previously installed UFSD driver in /lib/modules/6.5.10-200.fc38.x86_64/
Preparing to install
cat: config.log: No such file or directory
Error: Can’t prepare driver configuration

  1. If I use sudo passwd root to create a temporary root password, I still get the same error. I used sudo passwd -l root to remove it afterwards.

Apparently on Ubuntu and Zorin, there’s a workaround using apt-get: Paragon NTFS Driver Install - #2 by Aravisian - General Help - Zorin Forum

Fortunately, I can still read HFS+, but it would be very useful to be able to write to it too.

P.S. After further attempts, and other updates, I can no longer connect to the internet, and can no longer read HFS+. I guess I will have to check my Vorta backups and reinstall Linux again.

P.P.S. I can connect and read again. Maybe I opened a buggy build in grub that time.

Did you follow the instructions and installed the requirements to build the driver?

Quoting from their FAQ, section Installation: Microsoft NTFS for Linux by Paragon Software - Introduction

A development environment is required to compile Linux drivers and utilities. Please verify that these tools are functional. The easiest way is to choose the developer toolkit when installing Linux.
What must be installed:

kernel source code (recommended) or header files (doesn’t always work) for the kernel
GNU C (gcc) compiler (version 3.3 or higher is required)
GNU C++ (g++) compiler
GNU glibc-static library
GNU Make
GNU ld (binutils)
Modutils (module-init-tools)
DKMS library

this would be something like

sudo dnf install make automake gcc gcc-c++ kernel-devel kernel-headers dkms binutils kmod

Disclaimer: I have never compiled or used that driver, list of above requirements may be incomplete.

1 Like

No, I didn’t see that section. I tried to follow the instructions in the readme file.

Since then, I installed those files, created a root password, logged out, logged in as root, disabled effects and switched themes and disabled cursor blinking in the terrminal so I could see, tried the same command as root, got the same error, logged out, logged in as myself, and removed the root password.