Invalid image on bootable usb

Been trying to create a bootable usb so I can try fedora. No matter what technique I try, I end up with an “invalid image” error. On my Surface Pro 3 the message is hard to read as the font is microscopic. It’s only there for about 2 seconds.

I used Media Writer, the dd command, and balenaEtcher, none of which gave errors. On reboot, I get the aforementioned error message.

I tried three flavours of fedora. Workstation, Kinoite, and KDE Plasma. They all had the same error.

Is there something I am missing? Do I have to prepare the USB stick in a particular way?

I am sooo frustrated.

There is no advance prep needed.

Please provide the exact filename of the iso in use, and the exact dd command used to write to the usb.

Also, if you have a system already booted please mount the usb device and show us the result of running sudo fdisk -l and lsblk -f

What architecture is the surface pro 3? Arm or x86?
What architecture is the image you put onto the usb intended for? (the name should tell us)

You are using kinoite so it is even more critical that things are correct because kinoite does not have a live media image, but only installs directly.

Not sure how to paste results of fdisk and lsblk
both show 3 partitions on sdb
from lsblk -f
sdb1 is iso966 Jolie Fedora-Knt…
sdb2 is vfat FAT16 ANACONDA
sdb3 has no info
from fdisk -l
sdb1 is microsoft basic data
sdb2 is EFI System
sdb3 is microsoft basic data
Surface Pro is x86
dd if=Fedora-KDE-Live-x86_64-39-1.5.iso of=/dev/sdb
dd if=Fedora-Kinoite-ostree-x86_64-39-1.5.iso of=/dev/sdb

Does that help?