Intel i915 Ice Lake GPU driver N/A, nothing helps

This issue actually applies to all Linux distros (I tried 10, I think) as well as BSD-derived operating systems (tried FreeBSD, OpenBSD, GhostBSD, NomadBSD, etc) and even Widows (refused to install, demanded drivers on a USB stick first). Ubuntu simply froze even before attempting installation – at GRUB screen.

The reason I’m asking it here is because Fedora is the only OS that I managed to install and which booted with correct monitor resolution and is usable. All the other ones would simply go blank with “no signal” screen as soon as they hit the boot instruction to start X or load drivers.

Fedora booted, but using “Software Rendering” for Wayland/GNOME and in Settings -> About -> Hardware Information it says exactly that.

First thing I did – followed these Best Practices page – it didn’t help. A number of related issues can be found on this forum as well other distros forums, but none helped.

I also managed to install Cinnamon desktop on Fedora. Logging in into it in normal mode at first appears good – the compositor is visibly present. However once I play a video file, I can clearly see it actually isn’t using the GPU acceleration. I tried to play videos in VLC, Videos and mpv – mpv refused to even start. Then I checked which driver is being used in Cinnamon settings and it was using mesa – I think, this is because I manually installed the mesa driver with $ sudo dnf install mesa-dri-drivers at some point.

In any case, I have not found a solution.

My machine is a BMAX mini-pc running with (copied from settings → about → System details):

  • Model: AMI Intel
  • Memory: 16 Gb
  • Processor: Intel® Core™ i5-1030NG7 × 8
  • Graphics: Software Rendering
  • Firmware version: V1.4_225
  • OS Name: Fedora Linux 39 (Workstation Edition)
  • Windowing System: Wayland or X
  • Kernel: Linux 6.5.6-300.fc39.x86_64

It really is quite something with those drivers – in 20+ years I have not seen a case where no operating system can install itself correctly, while they clearly should have done so.

If anybody here can advise on installing the driver and/or changing some BIOS settings (I tried a few as well as reset to default). Quite simply, this is unacceptable and I’m I’m still not sure whom to blame: Linux Kernel or Intel. The reason I think it might be the Kernel issue is because on FreeBSD a lot of things are ported from Linux and i195 driver too was ported from Linux. Intel’s CPU on my machine isn’t brand new – 11th generation – and the expectation was that it’d be supported out of the box on most operating systems.

This is the default install kernel for F39 when doing a new install.
I suspect that if you do a full upgrade with sudo dnf upgrade in a terminal window it may help since the kernel and much other software including drivers and firmware have been updated since F39 was released.

I am not sure that the i915 driver is able to do hardware acceleration though.

Please post the output of inxi -Fzxx as preformatted text that you copy and paste using the </> button on the tool bar to retain on screen formatting for us.