Installing nvidia drivers

Firstly, this is my third day trying to use fedora. A soul please show up and help me with that, I don’t want to go back to windows.

I installed fedora on a pen-drive(Kingston datatraveler USB 3.2 gen 1) using another pen-drive with live boot. For a couple of reasons I am not allowed to install on the computer at the present.

With my third try In installing nvidia drivers(gt 710), the system couldn’t boot up anymore so, I can’t get these infos on the terminal right now.

Let me start saying what I tried to do and what happened.

How to Install Nvidia Drivers on Fedora Linux
I followed this one if I remember right, and I got the message on boot “nvidia kernel module missing. Falling back to noveau”
As this obviously says that I’ve failed, using this message lead me to…

2°can’t find the specific topic where a guy helped but this is the thing I did to make it work
1- <Sudo dnf remove nvidia - -noautoremove - - exclude=nvidia-gpu-firmware>
2- <Sudo dnf install akmod-nvidia-470xx - - disablerepo rpmfusion-nonfree-nvidia-driver - - enablerepo rpmfusion-nonfree>
3- <“dnf list installed nvidia” after 5mins>

Which even made the boot change(3 squares loading instead of fedora loading together with motherboard), monitor off on and black screen with mouse as an X, like it is still loading, log in screen and then the same thing happened on the monitor to get on the workspace.
I tried a game before and after, was working fine before wine stopped working. And I noticed that the font was glitched, disappeared until I interacted with it in some when(when possible) so it was getting a bothersome to read. And this was affecting some programs too, modrinth for example to test a small game, was completely blank on it, impossible to do anything.

3° I tried on the “normal” way through the nvidia website with this video
(Fedora 40/39/38 NVIDIA Drivers Install Guide [550.78 / 535.171.04 / 470.239.06 / 390.157 / 340.108] :: If Not True Then False)
I could make everything until the step “2.6.5”, that one doesn’t seemed to work but I followed anyways. (I don’t even know what exactly this do)
Following the video, I did the same thing on it but everything failed “2.9.3 2.9.4” as the installation itself.
<systemctl set-default> didn’t worked, so I used the graphical instead… And I couldn’t boot up anymore.

The latest version of the nvidia drivers for that GPU is the 470xx driver.
To install that driver you must first enable the rpmfusion repo as shown here then install the driver.

If you already have installed a driver that is not the proper version you must (before installing the 470 driver) remove that other driver with sudo dnf remove \*nvidia\* --exclude nvidia-gpu-firmware --noautoremove.
The proper driver can then be installed with sudo dnf install akmod-nvidia-470xx as shown here.

Be aware that the 470xx drivers and older do not support wayland and you will only be able to use the xorg DE when you log in. This may be the reason you had glitches after installing the driver in steps 1 & 2.

Step 3 is not the normal way. I have seen nothing but errors when users try to follow the instructions from INTTF.

The packages from rpmfusion DO NOT use dkms and that appears to be one of the problems with INTTF.

My suggestion –
remove everything installed from INTTF and disable the INTTF repo then start over with the packages from rpmfusion that are specifically tweaked and tested for use with fedora. Packages from those two sites are quite likely to conflict and interfere with each other.

1 Like

I have seen you a lot here, thanks for helping me!

SIr, I have enabled rpm, put the nvidia drivers and put xorg and it is like that:
Screenshot from 2024-05-17 08-13-14

I get this crash message every boot I do and the log is like that(don’t know if this means something about it)
Now that is not wayland anymore, it is still like that as you can see on the gif.
I have done something wrong again?

also, before updating the drivers I had gnome, gnome classic. gnome classic on xorg and gnome on xorg.
now I just have gnome classic and gnome, none selected.
I had put gnome on xorg before the update

update: wine seems to be working now at least, I can play games!

I just recently did an update on a machine that has older nvidia GPU installed (GTX 1050)
I find that with the 6.8.9 kernel it will not compile the needed drivers. I use the 535 driver which was replaced just after fedora 39 was released since that gpu will not run cuda 12.3 or 12.4 and the 535 driver was the last to use cuda 12.2. Now with an update to the 6.8.X kernel it will no longer compile the modules for the 535 driver so I am still running the 6.7 kernel on that system. I guess I will eventually upgrade the gpu there but for now am using an older kernel and nvidia driver version.

In the process of trying the newer kernel I found the same issue you describe in booting. My fix was to select ‘gnome’ from the 2 choices given then logging in. Inxi showed that I was running the nouveau driver with x11. When I then logged out and back in I now see the original 4 choices of DEs available and was again able to select the ‘gnome on xorg’ choice.

so, there’s no solution for me?
I tried this inxi to see if it was the same case, but didn’t see nothing written noveau. Inxi -Fxz
is what I used according to some people.
but I saw something strange there, what’s Xwayland?

Also, why is this one red?
Screenshot from 2024-05-17 17-15-57

I don’t have a solution but I would suggest to use a distro that is made on purpose to run from a pen drive. There are some, last I tried was Tails which is aimed for “privacy” through the use of TOR. Once upon a time I tried Kanotix, based on Debian and Slax, based either on Slackware or Debian.

I didn’t throughougly read through the attempts, but this is exactly what I did to install NVIDIA drivers back in early 2023 on Fedora 37 with a RTX 3060:

Add RPM Fusion free:

sudo rpm --import '' && sync && sudo dnf install ''$(rpm -E %fedora)'.noarch.rpm' -y && sync

Add RPM Fusion nonfree:

sudo rpm --import '' && sync && sudo dnf install ''$(rpm -E %fedora)'.noarch.rpm' -y && sync

Packages and driver install:

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda xorg-x11-drv-nvidia-cuda-libs vulkan vdpauinfo libva-vdpau-driver libva-utils -y && sync && sudo akmods --force && sync

And rebooting was fine. The key parts are adding both RPM Fusion’s free and nonfree repos, installing akmod-nvidia, and making sure NVIDIA’s kernel module gets installed before reboot with akmods --force.

Unless the akmod-nvidia package name changed or they aren’t using akmods anymore, I don’t see why that wouldn’t work today on F40. I only used Workstation and don’t know how that works on Silverblue or anything else. I also didn’t try the NVIDIA-specific RPM Fusion repo.

I see akmod-nvidia-550.78 on the regular nonfree repo and imagine those above commands should be fine.

Xwayland is a compatibility layer that allows applications designed for the older X11 to run on desktops that use the newer Wayland protocol.

I’m going to say you need a different Desktop, Instead of using Gnome, maybe try something like XFCE, or LXQT or i3 WM ? For your specific use case of needeiong to be on a USB drive, I wouldn’t go with a distro that can make a lot of use of the GPU. Something light weight is better.

For XFCE :

For LXQT :

There are others here :

These should work better and have better X11 support OOTB as well.

Reinstall with one of these spins, Add the 3rd Party Repos, update the system with
dnf -y distro-sync && dnf install xorg-x11-drv-nvidia-470xx akmod-nvidia-470xx

1 thing to note, since you are using a Computer that you cannot install on, If this Computer has a TPM, SecureBoot and a Windows installation you might be out of luck with this type of build. Give it a try and see what happens.

If your system can’t boot from a USB key you may still be able to use a WSL distro in Windows. Some colleagues who are stuck with “Enterprise Windows” and 2-factor authentication are using WSL.

1 Like

that tails is nice, but I want a normal experience from linux.

I tried that way and got ‘‘nvidia kernel module missing’’, apart from other things :sweat_smile:
that was when I changed now to xfce in case

thanks for recommending another desktop! I am now with xfce and everything is working fine with nvidia drivers.

the only problem is that I don’t know how to install a .deb or .appimage program.
only .rpm seems to work on that dnfdragona

1 Like

Right-click the appimage → Properties → mark as executable (or chmod +x it :p) and it should work from wherever it’s located. That’s not quite installing it though and I’m not sure if there’s a standard location is to put AppImages

well, I could but through usb. the only problem was the nvidia drivers causing problem on gnome because of wayland or something like that, it seems.

I would think GDM or Mutter would automatically force Xorg on unsupported drivers, but I also thought NVIDIA had good-enough Wayland support by now to at least get to log-in and the desktop.

For future reference, this one-liner disables Wayland entirely with GNOME (also fine on F40/GNOME 46):

cat '/etc/gdm/custom.conf' | grep '#WaylandEnable' > '/dev/null' && sudo sed -i 's/'#WaylandEnable=false'/'WaylandEnable=false'/g' '/etc/gdm/custom.conf' && cat '/etc/gdm/custom.conf' | grep 'WaylandEnable=false'

mark as executable is not installing though.
it is like I am opening an .exe
that result on an error, or the problem that happened with nvidia drivers is weaker. because modrinth got the same problem as before, even though there’s no font glitch anymore.

my graphics card is very old, maybe is because of that. I can log in but font gets glitched and some programs seems to have strange problems after drivers installation.

I will save that command, maybe it comes handy someday, thanks

1 Like

The OP has a GPU that needs legacy drivers. They cannot use Wayland.

NVIDIA GK208B [geForce GT 710] driver nvidia v: 470.239.06

Ferdora does not use .deb files that is for Debian, Ubuntu, Pop!_OS type of systems. Fedora is an .rpm distro of Linux. If you need software, you can look it up “X app on Fedora” if it’s a command line tool there are sites like to see packages in a Debian distro, and what it’s called on Fedora so you can install using the dnf tool from the Terminal.

appimages should run on Fedora, but you need to make them executable. Also, Flatpaks is fully supported on Fedora and many appimages are in the Flathub repository.


Short answer is “you can’t”
apt is used on ubuntu to install packages (.deb files)
dnf is used on fedora to install packages (.rpm files)

Generally a user would install the ‘appimage’ by placing it into ~/bin then mark it as executable as shown by @Espionage724 in post 13 above. It can then be run by entering the file name on the command line, double clicking on it in the file manager, or creating an alias command to change the name to something easier to type.


Now that you two have say that, I remembered something.
When I tried opening a .deb file, I got sent to package installer on gnome, that’s why I thought it was strange. Now I remembered that bellow the install button was called a flatpak, not deb.

There’s so many things that’s getting me confused, but is nice too