Installing Fedora 30, shuts down right after "[ OK ] Started Gnome Display Manager" on Dell Inspirion 15 5000 Gaming

I’m trying to install Fedora 30 Workstation on Dell Inspirion 15 5000 Gaming (NVidia GeForce GTX 1050, if that matters). I created a LiveUSB using official creator for Win10.

My problem is, it starts to boot, I do not see the Fedora loading logo but instead I see all logs with [ OK ] at the beginning, it reaches “[ OK ] Started Gnome Display Manager”, then nothing happens for a few seconds… and then shuts down “gracefully”, no errors, all “[ OK ] Stopped this and that”.

I noticed that switcheroo-control was failing so I switched of “Secure Boot” as advised somewhere on the Internet, that fixed switcheroo-control but did not fix my problem, so I guess it wasn’t related…

I can boot Fedora 30 in troubleshooting mode just fine, Gnome works, WiFi, etc.

I am willing to provide any logs you want if you tell me how to extract them-right now I have no idea how since the system does not really allow me to do anything.

I will appreciate any help, I was working on Fedora on my old laptop for a few years, and now I’m stuck with Win10 :cry:

EDIT: I Just tried Fedora 30 Silverblue, still no luck.

1 Like

Habe you tried a different USB? Die you check the checksum oft the downloaded ISO? I reccomend in trying to download an ISO, verfying the checksum and creating an USB using rufus.

tl;dr: graphics issues? Most likely nvidia’s fault.

The issue is most likely the Nvidia Graphic card. There are two different drivers for nvidia cards:

  • nouveau, included in fedora: free driver (built by reverse-engeneering proprietary tools) but does not suport every card and (often) offers poor performances.
  • nvidia, not included in fedora: this is the proprietary driver (= binary blob, we don’t know what’s inside) provided by nvidia.

I suspect you’ll have to use the nvidia proprietary driver to get a working system and reasonable performances. The troubleshooting mode works since it (I guess?) use CPU rendering (which is highly inefficient) in order to avoid graphics issues. You can try to disable nouveau/use CPU rendering during the installation and install the proprietary driver afterwards.

Note that you might have the nvidia’s Optimus technology on your laptop, which means you can use a small low-power graphic card integrated in you CPU (different from what I called CPU rendering before) most of the time and only use the nvidia card when required (better performance but larger power consumption). In that case just disabling nouveau (by editing the kernel’s arguments) at boot or forcing integration graphics (= disabling discrete nvidia card) in the BIOS might do the trick to get a working system.

I don’t have much time for detail right now, I hope it helps nonetheless.